'.1. 2)%' AUTODESK UNIVERSITY 2013

Introduction to Visual Basic® for Applications for
Autodesk® AutoCAD®

Lee Ambrosius — Autodesk, Inc.

CM1560-L Visual Basic for Applications (VBA) is a programming environment that allows you to
automate tasks using the Visual Basic programming language. This hands-on lab explores how to
access and use the VBA integrated development environment (VBAIDE) and work with the Autodesk
AutoCAD object model. You learn to work with data, manipulate AutoCAD software objects, get input
from a user, store values, work with basic conditionals, and other programming concepts. This is a
beginner-level class for VBA programming and is not something you want to take if you already have
experience with VBA programming.

Learning Objectives
At the end of this class, you will be able to:

e Create and load a VBA project file from the VBA integrated development environment
o |dentify the classes, properties, and methods that are available in the AutoCAD object library
e Create and modify objects in the current drawing

e Collect input from the user via the command line or UserForm

About the Speaker
Lee is a Principal Learning Content Developer on the AutoCAD® team at Autodesk and has
been an AutoCAD user for over 15 years in the fields of architecture and facilities
management. He has been teaching AutoCAD users for over a decade at both the corporate
and college level. He is best known for his expertise in programming and customizing
AutoCAD-based products, and has 15+ years of experience programming with AutoLISP®,
VBA, Microsoft® .NET, and ObjectARX®. Lee has written articles for AUGI® publications and
white papers for Autodesk on customization. He is the author of several books on AutoCAD
and has been an active technical editor for the AutoCAD Bible series.

Twitter: http://twitter.com/leeambrosius
Email: lee.ambrosius@autodesk.com

Blog: http://hyperpics.blogs.com
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1 Getting Started

Everything you need to get started using VBA in AutoCAD is pretty much provided for you by
Autodesk, but in more recent releases you do need to perform one additional step. The VBA
development and runtime environment is not available as part of the AutoCAD installation
download or on the physical media, but must be download separately from autodesk.com and
then installed.

You can tell if the VBA environment has been installed by trying to execute one of the VBA
related commands in AutoCAD. If the environment has not been installed, the following
message box is displayed:

VBA - Not Installed S

! . Microsoft® Visual Basic® for Applications software
= (VBA] is no longer installed with AutoCAD. For more
information, please visit:

http: fwww. autodesk.com/vba-download

L -

Clicking the link in the message box, http://www.autodesk.com/vba-download, opens your
default web browser so you can download and install the VBA environment. Once your web
browser opens, download the appropriate installer for your AutoCAD release and version.

After the VBA environment has been installed, you can perform the following tasks:

o Load a VBA project

o Create a new VBA project

¢ Add new and modify existing components of a VBA project
e Add and change library references

e Create and execute macros

e Debug macros and UserForm procedures

VBA Projects

A VBA project contains the code modules and UserForms that define the logic of your custom
program. VBA projects are stored in files with the .dvb extension. Each VBA project contains at
least one component named ThisDrawing, and must reference two libraries.

The ThisDrawing component is a specially named class module that represents the active
drawing in the AutoCAD environment. Normally, a class module is used to define a new
programming object, including its properties and methods.


http://www.autodesk.com/vba-download
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In addition to the ThisDrawing class module, a VBA project can also contain one or more of the
following components:

e Standard code module — Code modules that are used to store procedures, data types,
and variables that can be accessed from anywhere in your project.

¢ Class module — Code modules that define user-defined objects. Class modules are not
common to most VBA projects, with the exception of ThisDrawing, but they can be
helpful when creating reusable libraries that might be used in multiple projects to avoid
procedure naming conflicts and to hide variables and functions from your entire project.

e UserForm — A dialog box interface object within a project. Contains controls that the
user can interact with to provide values to your custom program. UserForms can be
displayed as modal or modeless.

The two libraries that the VBA project must reference are:

e Visual Basic For Applications — VBA design time environment
e AutoCAD <release> Type Library — The object library that defines the interfaces that
allow you to work with the AutoCAD application, drawings, and objects within a drawing.

AutoCAD Type Library

The AutoCAD Type Library, also referred to as an object library, contains the interfaces that you
can interact with to automate tasks in AutoCAD. Interfaces are commonly also referred to as
classes. To help you navigate the classes of and their relationship in the AutoCAD Type Library,
you can utilize the AutoCAD Object Model which is a hierarchical structure. The Object Browser
of the VBA IDE allows you to quickly see all of the available classes of the referenced libraries
in your project, and their properties and methods. You can even directly access a help topic
associated with each of the items shown in the Object Browser by selecting the item and
pressing F1.
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AutoCAD Commands
After the VBA environment is installed, the following commands are available for use:

e VBAIDE - Launches the AutoCAD Visual Basic for Applications Integrated Development
Environment
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e VBALOAD - Loads a previously saved VBA project (DVB) file

e VBAMAN - Displays the VBA Manager.

¢ VBANEW - Creates a new VBA project (DVB) file and loads it into the current VBA
environment.

e VBAPREF — Displays the Options dialog box for the VBA environment.

¢ VBARUN - Displays the Macros dialog box which allows you to execute or debug a
macro in one of the loaded VBA projects.

e VBASTMT — Executes a VBA statement at the AutoCAD Command prompt.

e VBAUNLOAD - Unloads a VBA project.

e -VBALOAD - Loads a previously saved VBA project file at the AutoCAD Command
prompt.

¢ -VBARUN - Executes a macro in one of the loaded VBA projects at the AutoCAD
Command prompt.

AutoLISP Functions
In addition to VBA related commands, there are a few AutoLISP functions that are also available
upon installing the VBA environment:

e vl-vbaload — Loads a previously saved VBA project (DVB) file.
e vl-vbarun — Executes a macro in one of the loaded VBA projects.

Both of these functions require you to first make a call to the vl-load-com function.

VBA Related Terminology
Before you get started working in the VBA environment, you should be familiar with these
programming terms:

e Class — Definition of an object; template that is used to create an instance of an object.
Defines the properties and methods that describe and manipulate an object.

¢ Object — An instance of a class that exposes its properties and methods.

o Property — Named attribute that describes an object at runtime. Can also be changed at
design time for UserForms and controls using the Properties window of the VBA IDE.

¢ Method — Function that performs an action on a specific object.

e Debug — Process used to interactively step through source code and evaluate the
results in realtime.

e Statement — Line of code that is executed when you run a macro or interact with a
control on a UserForm.

e Comment — Statement that provides information within a code module that is not
executed. Comments start with an apostrophe, and anything to the right is ignored
during execution.

e Runtime —When a procedure within a project is being executed; UserForms and
controls can only be modified through code.
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¢ Design-time — When the objects within a project can be created and modified using the
Visual Basic for Applications IDE.

2 Working with VBA Projects

VBA projects must be loaded into the VBA development environment before they can be edited
or used. Editing a VBA project is handled in the Visual Basic for Applications Integrated
Development Environment, or commonly known as the VBA IDE. The VBA IDE is displayed by
clicking Manage tab » Applications panel » Visual Basic Editor on the ribbon, or entering
vbaide at the AutoCAD Command prompt.

The VBA IDE contains a hnumber of tools that are used to add and modify the components of a
loaded VBA project. The following illustration calls out the main components of the VBA IDE you
will want to become familiar with:

Editor window Toolbox
(UserForm) window Object Browser
#9 Microsoft Visual Basic for Applications - Glaball I = | E S|
Eile Edit View Inset Fommat Debug Run  Tools Addns  Window Hel
ME-d rouo K Y EF Y :
Project - ACADProject x| " - " E—
Globall - UserForm1 (UserForm) = %% Object Browser o= ][=]
== T e—
- B —1 | [<anLibraries> M 1
Project =% ACADProject (Globall) UserForml == Toolbox (=]
=5 AutoCAD Objects o - #
Explorer _E® ThisDraving Cantrols |
S48 Forms - Search Results
D o Uearrormi 3 z: abl :‘ [ Liorary Class Member |
T G |
B = == [ E
jeeoooooooosacooooanoo0oaac00aaac000a00y 4 o = Classes Members of ‘Acad3DPol
Properties - UserFarml x| £ 1= B Acad3DSolid + |-® Appendvertex =
UserForm1 UserForm - ) AcadAcCmCaolor Application
Aphabetc | Caegorized &) AcadApplication & ArrayPolar
= — & AcadArc & ArrayRectangular
ame serForm a o~
Proper‘tles |:| SHB0DD00OFE. =] & Acadatrribute Closed
A d I . ~ | B3 AcadattributeReferer Coordinate =
window order Color EHE00000128 B} AcadBlock Coordinates 1
BorderStyle 0 - fmBorderStyleNone !
Caption UserForm 1 ) Globall - ThisDrawing (Code) = | === g-ﬁtﬁﬂﬂ‘ﬂcmemem = Copy
Cyde 0 - fmCydealForms . AcadBlocks = Delete
orawuer 22000 | (General} +  (Declarations) ~ | @ Acadcircle Document
Enabled True 3 | & AcadDatabase EntityTransparenc
Font Tahoma @ AcadDatabasePrefe  |=@ Explode
ForeColor W 24300000128 21 AcadDgnUnderlay =@ GetBoundingBox
Height 180 2} AcadDictionaries =& GetExensionDicti
HelpContextlD 0 ) AcadDictionary & GetXData
KeepScrolBarsvisible 3 - fmScrolBarsBoth ) AcadDim3PointAngL Handle
Left o £| | B AcadDimaligned HasExtensionDicl
Mouselcon (Wone) &1 AcadDimAngular =& Highlight
MousePointer 0 - fmMousePointerDefault [ AcadDimArcl ength Hyperinks
E!CEEA\ . [ZNE';:;_ —" p— B AcadDimDiametric & IntersectWith
»—:E re ‘gnmi o 7””?:: re ‘gnmi ‘;n T ) AcadDimension Layer
ctureTing Fae A ~ | & AcadDimOrdinate  ~ Length -
RightToLeft False S =IE < m » Class Acad3DPolyline =

Editor window
(Code module)

o Project Explorer — Provides access to the components of all loaded VBA projects.
These components include standard and class modules, and UserForms.

e Properties window — Provides the ability to view and modify the properties of a
selected component from the Project Explorer or an object selected in the form editor
window when editing a UserForm.

e Editor window — Provides access to the code of a component in a loaded VBA project
or the form editor for a UserForm.
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Toolbox window — Provides access to the controls that can be placed on a UserForm.
Object Browser — Provides a view into the libraries that are currently referenced to a
VBA project.

Exercises

This section contains all the exercises for this lab and for when you get back to the office.

E1l

Loading a VBA Project and Executing a Macro

This exercise demonstrates how to load a VBA project file named EX1 — Hello World.dvb and
execute a macro named HelloWorld.

In AutoCAD, on the ribbon, click the Manage tab.

2. Onthe Manage tab, click the title bar of the Applications panel and then click Load

Project.

Output  Plug-ins  Autodesk 360  Feature

Elmport LT& ! %‘Ji:ualBa:ic Editor | £
el

3 Export lod R Visual LISP Editor | 4
oa wun

? Edit Aliases = | Application Script E Run VBA Macro E

stion

uﬁ% Load Project
% E VBA Manager

{1 Applications

In the Open VBA Project dialog box, lower-left corner, clear the Open Visual Basic Editor
check box.

Browse to C:\Datasets\Thursday\CM1560-L Introduction to Visual Basic® for
Applications for Autodesk® AutoCAD® and select the EX1 — Hello World.dvb file. Click
Open.

|A Open VBA Project [
Look in: - O ¥ £ M~
D= Name : Date medified Type
el } 11/6/20133:40 PM  File folder
Recent Places TN ERTTiilo World.dvb 10/16/3013 540 B AutoCAD
Desktop |
|
=l
Libraries
REM4CZII80RQ < i v
L
. File riame: EX1 - Hello World dvb -
Qn.\" Files of type [Proiect dvb) - [ Caced |
[ Open Visual Basic Editor
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5. In the File Loading — Security Concern dialog box, click Load.

A File Loading - Security Concern @

A Anexecutable file was found outside of the specified trusted locations. What
0 do you want to do?

C\Datasets' Thursday " CM1560-L Introduction to Visual Basic® for Applications
for Autodesk® AutoCADENEX] - Hello Word dvb

Make sure that this file comes from a trusted source and does not contain
malicious code.

| load || DoNoiload | [ Hep |

L 4

WARNING! — Do not click the Close or Do Not Load buttons unless you do not want to
load the file. Doing so, will require you to close and restart AutoCAD to load the file.

6. Inthe AutoCAD message box, click Enable Macros.

A AutoCAD e
C:\Datasets' Thursday CM1560-L Introduction to Visual Basic® for
Applications for Autodesk® AutoCADENEXT - Hello Word dvb contains
Macros may contain vinuses. It is always safe to
disable macros, but if the macros are legitimate, you More Info
might lose some functionality.
Abhways ask before opening projects with macros
[ Disable Macros ] [ Enable Macros ] [ Do Mot Load

7. On the ribbon, click Manage tab > Applications panel » Run VBA Macro.

WENECM Cutput  Plug-ins  Autodesk 360 Featured

] Import I_T# ' % Visual Basic Editor EE

Export Wisual LISP Editor
b Load Run sl {
f Edit Aliases = | Application Script @ Run VBA Macro e
tion | Applications = |

8. Inthe Macros dialog box, select the macro ThisDrawing.HelloWorld in the EX1 — Hello
World.dvb project file if it is not already selected.

You will need to scroll the Macros list to see the full name of the macro since the folder
path is so long.
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9. Click Run.

r‘ Macros

Macro name:

The Macros dialog box closes and a message box titled AU2013 is displayed. Along with
the message box, the message Hello World! is displayed in the Command Line window.

[ Auz013 [

Command: _wvbarun
Hello World!

[~ VBARUN

10. Click OK to dismiss the message box.

E2 Working with the Visual Basic Editor and the ActiveX Documentation
This exercise demonstrates some of the basics of the VBA environment and using the ActiveX
Documentation.

1. In AutoCAD, on the ribbon, click Manage tab.

2. Onthe Manage tab, click the title bar of the Applications panel and then click VBA
Manager.
Output  Plug-ins  Autodesk 360  Feature
J Import |_T$, - [ Visual Basic Editor | £
3 Export load Rum [ Visual LISP Editor | 4
§ Edit Aliases = | Application Script [ Run VBAMacro | E

ation
L Load Project
VBA Manager
{1 Applications

10
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In the VBA Manager, Projects list, select EX1_Helloworld and click Unload to remove
the project from the VBA environment.

r‘ WVBA Manager ﬁw
Drawing
[meing1.dwg v]
Embedded Project: finone) Extract
Projects
MName Location Embed

EX1_HelloWord C:ADatasets' Thursday CM1E

Save as...

Load
Unload

1 Ee

4 1 | b Macros...

Visual Basic Editor [ Close l

- ’y

Help

Click New to create a new VBA project.

In the Projects list, select ACADProject and click Save As.

Projects
Name Location Embed
Giobal4

Saveas...

In the Save As dialog box, browse to the C:\Datasets\Thursday\CM1560-L Introduction
to Visual Basic® for Applications for Autodesk® AutoCAD® folder.

In the File Name text box, clear the current text and type MyVBAProject. Click Save.

In the VBA Manager, lower-left corner, click Visual Basic Editor.

11
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9. Onthe menu bar, click Tools » ACADProject Properties.

a —
a Microsoft Visual Basic for Applications - Ch\Datasets\Thursday\CM1560-L Introduction to Visua

File Edit View Insert Format Debug Run

Add-Ins Window Help

™ k- s A 34 ool EY  References...
Project - ACADProject x| Additional Controls

B

—-#% ACADProject (C:\Datasets\Thursday(

Macros...

Opticns...

-5 AutoCAD Objects

ACADProject Properties...

10. In the ACADProject — Project Properties dialog box, clear the value in the Project Name

text box and type MyVBAProject. Click OK.

r B!

Project Mame:

MyVBAProject
[ [

11. On the menu bar, click View » Object Browser.

-
a Microsoft Visual Basic for Applications - CA\Datasets\TI

File Edit | View | Insert Format Debug Run
M- g & Code F
Project - MyVE| =2| Object Shift+F7
E Definition Shift+F2
Elgﬁ MyVBs Last Position  Ctrl+5Shift+F2
E%%ﬂ 27 Object Browser F2
1 Immediate Window  Ctrl+G

12
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12. In the Object Browser, Search box, type addline and press Enter.

P )

& Object Browser == ]
[mu Libraries> v] ‘ P
iy acicline -
Search Resulis
Library Class Member
I"h AutoCAD m AcadBlock = AddLine
e M auocaD [l cadModelSpace AddLine
i AutoCAD 1 AcadPaperSpace = AddLine
Classes Members of ‘AcadModelSpace”
B AcadMenuBar » =% AddEllipse -
21 AcadMenuGroup =% AddEllipticalCone
B AcadMenuGroups =% AddEllipticalCylinder
B AcadMinsertBlock =% AddExtrudedSolid
B AcadMLeader =% AddExtrudedSolidAlongPath
1 AcadMLeaderLeade =& AddHatch
21 AcadMLeaderStyle =% AddLeader
B AcadMLine =% AddLightWeightPolyline
BliAcadModelSpace | . |«®iAddLine 1.
Function AddLine( StartPoint, EndPoint) As AcadLline -
Member of AutoCAD. AcadModelSpace =
Creates a line passing through two points

13. In the Search Results section, select one of the listed results and press F1.

14. On the AddLine Method topic, click the Example link near the upper-right corner.

[ Autodesk AutoCAD 2014: ActiveX Reference Guide = | |
Hide Print  Options
Q:-rrterrts| Index | §earch| Favori_te5| AUtOCAD
Bl AddLine Method ~
2] AddMenuttem Method .
7] AddMinsertBlock Method AddLine Method

2] AddMLeader Method
2] AddMLine Method
2] AddMtext Method
2] AddObject Method See Also | Example
2] AddPaint Method
2] AddPolyfaceMesh Method Signature
2] AddPalyline Method
[2] AddPViewport Method RetVal = object.hAddLine (StartPoint, EndPoint)
2] AddRaster Method
[2] AddRay Method Object
2] AddRegion Method

2] AddRevolvedSolid Method
2] AddSection Method

B I S, LX IV

Creates a line passing through two points.

m

Block, ModelSpace Collection, PaperSpace Collection
The objects this method applies to.

13
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15. Highlight the example code under the section titled VBA Example.

w

-
EQ Autodesk AutoCAD 2014: ActiveX Reference Guide

T e & 6

Hide Back  Prnt Options

Contents Igdexl §ear\'.:h| Favorites

2] Add Example

2] Add3DFace Example
2] Add3DMesh Example
2] Add3DPoly Example

2] AddArc Bxample

2] AddAttribute Example
2] AddBax Example

2] AddCircle Example

2] AddCone Example

2] AddCustominfo Example
2] AddCustomObiject Example
2] AddCylinder Example

E AddDimAligned Example

ﬂ AddDimAngular Example

2] AddDimArc Example

E AddDim Diametric Example
2] AddDimOrdinate Example

2] AddDimRadial Example

[2] AddDimRadialLarge Example
2] AddDimRotated Example

E AddHlipse Example

_?] AddHlipticalCone Example
< | T |

?| ADClnsert Units Default Target Exar -«

z AddDim3Point Angular Example

AutoCAD

AddLine Example

VBA Example
Sub Example AddLine ()
" This example adds a line in model space]

Dim 1lineCbj &s AcadLine|

Dim startPoint(0 To 2) As Double]
Dim endPoint (0 To 2) As Doublel

" Define the start and end points for the line]
startPoint (0) = 14#: starcPoint (1)
endPoint (0) = 5%#: endPointc(l) = 5#: endPointc(2) = Of

' Create the line in model space]
Set lineObj = ThisDrawing.ModelSpace.BRddLine (startPoint, endPoint)

Using Programming Languages other than VBA  |_

= 1#: startPointc(2) = 0Of

16. Right-click over the highlighted code and click Copy.

17. Switch back to the VBA Editor using the Windows taskbar.

18. In the Project Explorer, on the left side, double-click the ThisDrawing class module to
open it in a code editor window.

19. Click anywhere in the code editor window that appears.

-
E Microsoft Visual Basic for Applications - C:\Data

™ -

Project - MyWVBAProject

=l=1{F]

File Edit View Insert

Format

Debug
P

x|

,
.

Egﬁ MyVBAProject (C:\Datasets\Thursday
E1-E5 AutoCAD Objects

14
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20. In the code editor window, right-click and click Paste.

The code editor window should now look like the following image.

2 C\Dataset=\Thursday,CM1560-L Introduction to Visual Basic® for Applications for Autodesk...

[General) + Example_AddLine

oo =]

Sub Example AddLine ()
' This example adds a line in model space

Dim lineCb]j As AcadLine
Dim startPoint (0 To 2) A= Double
Dim endPoint (0 To 2) A= Double

' Define the =start and end point=s for the line
startPoint (D) 1#: startPoint (1) 1#: startPoint(2)
endPoint (0) 5#: endPoint (1) S5#: endPoint(2) o#

' Create the line in model space
Set lineCbj = ThisDrawing.ModelSpace.RAddLine (startPoint,
ZoomAll

End Sub

0#

o |
e

m

endPoint)

21. On the menu bar, click File > Save.

-
E Microsoft Visual Basic for Applications - C\Datasets\Thursday\CM1560-L Introduction to Visual Basic® for Applic

Eile } Edit View Insert Format Debug Bun  Tools  Add-Ins  Window Help
|l Save C\Datasets\Thursday\CM1560-L Introduction to Visual Basic® for Applications for Autodesk® Au ||
P Import File... Ct+M |
Export File... Ctrl+E
= L
. ct
@ Print... Ctrl+P
A Close and Return to AutoCAD Alt+Q L

15
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22. In the code editor window, click between the statements Sub Example_AddLine()
and End Sub.

EuniIooIs Add-Ins  Window Help

e

Run Sub/UserForm

F5

;M pon @ OSE(EE AE R
Il Break Ctrl+Break + Example_AddLine
@ PReset N
& Design Mode = a2 linl 23 Il.odel space
Dim lineCbj As AcadLine
Dim startPoint (0 To 2) As Doukle
Dim endPoint (0 To 2) A= Double
\ ' Define the start and end points for the line
startPoint (0) = 1#: startPoint(l) = 1#: startPoint(2) = 0%
endPoint (0) = 5%#: endPoint(l) = 5%#: endPoint(2) = 0#

' Create the line in model space
Set lineCbj = ThisDrawing.ModelSpace.fAddLine (startPoint, endPoint)
ZoomAll

End Sub

23. On the menu bar, click Run » Run Sub/UserForm.

24. Switch back to the AutoCAD application window.

25. Select the line in the drawing area. Right-click and click Properties.

On the Properties palette, you should notice that the new line is drawn from 1,1,0 to
5,5,0.

x
'3 [ Line ‘Et% | I-—[&/ |
Color W Bylayer
Layer ]
Linetype Bylayer
Linetype scale  (1,0000
n Plot style ByColor
.’ Lineweight Bylayer
Transparency ByLayer
Hyperlink
Thickness 0.0000
Material ByLayer
o Start X 1.0000
StartV' 1.0000
Start Z 0.0000
End X 5.0000
End Y 5.0000
End Z 0.0000
Delta X 4.0000
Delta ¥ 4.0000
i DeltaZ 0.0000
‘é Length 56569
o Angle 45

16
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Create New Procedures
This exercise demonstrates how to add a new Public procedure named DrawCircle and a

Public procedure named MakeLayer.

1.

2.

In the VBA IDE, on the menu bar, click Insert > Module.

-
E Microsoft Visual Basic for Applications - Ch\Datas

File Edit VWiew Insertthrmat Debug [

™ E - - u

Project - MyVBAPrajed 2] UserForm

== % Module

E‘ﬁ MyVBAProjec| & Class Module
-5 AutoCAD O

In the Project Explorer, double-click the Modulel code module to make sure the code

editor window is opened and has focus.

E Microsoft Visual Basic for Applications - C\Datas

File Edit View Insert Format Debug

™ - A b

Project - MyWVBAProject H

= -

EI@ MyVBAProject (C:\Datasets\Thursday
EI% AutoCAD Objects

PooEe [E? ThisDrawing
=45 Modules

‘.48 Module1 *—

|
1]

17
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3. Inthe Properties window, click in the (Name) field and clear the current value. Type
basMain and press Enter.

-
E Microsoft Visual Basic for Applications - ChDatas

File Edit View Insert Format Debug
™ E- v [
Project - MyVBAProject x| [

= = @] Br

a--@i MyVBAProject (C:\Datasets\Thursday
£ AutoCAD Objects

.. |E® ThisDrawing
EI@ Modules
Ly2® basMain
1 | ] 3
Properties - basMain El
basMain Module -

4. Inthe code editor window, click anywhere so it has focus.

5. On the menu batr, click Insert > Procedure.

-
E Microsoft Visual Basic for Applications - Ch\Datasets

File Edit Wiew | Insert i Forrnat Debug Bur
m - | | 4 Procedure... il
Project - MyVBAProjec 2l  UserForm

=l &2 Module
E‘ﬁ MyVBAProjec; & Class Module
File...
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6. Inthe Add Procedure dialog box, Name text box, type DrawCircle.

Add Procedure

Mame: DrawCircde

=)
Type
@) Sub
) Function

) Property

Scope

@) Public
) Private

[] &l Local variables as Statics

L o

In the Type section, click Sub.
In the Scope section, click Public.
9. Click OK to create the procedure.
The following code should now be in the code editor window:
Public Sub DrawCircle()

End Sub

10. On the menu bar, click Insert > Procedure.

11. In the Add Procedure dialog box, Name text box, type MakeLayer.

12. Set the type of the procedure to Function and its scope to Public. Click OK.
The following code should now be in the code editor window:
Public Function MakelLayer()

End Function

13. On the menu bar, click File > Save.
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Adding a New Circle

This exercise explains how to add statements to the DrawCircle procedure that add a new
circle to model space.

1.

In the VBA IDE, Project Explorer, double-click basMain to open it in the code editor
window.

In the code editor window, click between the two statements that define the
DrawCircle procedure.

- T  wm 2= rJ wr [

J [General)

Public Subk DrawCircle()

- End Sub

Type the following:
Dim centerPt(0 To 2) As Double

Dim radius As Double

centerPt(0) = 2: centerPt(1) = 3: centerPt(2) = 0
radius = 3

ThisDrawing.ModelSpace.AddCircle centerPt, radius

On the menu bar, click File » Save.
Click in between the two statements that define the DrawCircle procedure.
On the menu bar, click Run > Run Sub/UserForm.

It might appear that nothing happened, but that is okay. If the Macros dialog box is
displayed, the cursor was not inside the DrawCircle procedure. Select the
DrawCircle macro and click Run.

s "
Macros &J
Macro Name:
prancrde]
ThisDrawing.Example_AddLine ance

Switch to the AutoCAD application window using the Windows task bar.

You can also click View » AutoCAD on the VBA IDE menu bar.
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8. Zoom to the extents of the drawing.

You should now see the new circle, and the line that was created when the
Example_AddLine was executed.

9. Select the circle in the drawing area. Right-click and click Properties.
10. On the Properties palette, review the properties of the new circle.
You should see that the circle has a radius of 3 and a center point of 2,3,0.

x
13 ’Circle
" [General - |
| 3D Visualization - |
Geometry -
Center X 2.0000
> Center ¥ 30000
Center £ 0.0000
&  Radius 3.0000
Diameter 6.0000
Circumference |18.8406
0 Area 28,2743
T Mormal X 0.0000
g Normal ¥ 0.0000
- Normal Z 1.0000

E5 Using the MakeLayer Procedure with the DrawCircle Procedure

This exercise explains how to modify the DrawCircle procedure so the new circle is placed on
a layer created by the MakeLayer procedure. You will also use the GetPoint and
GetDistance methods to request input at the Command prompt to specify the radius and
centerpoint of the circle.
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Right-click the Windows Start button, and click Open Windows Explorer or File Explorer
based on the Windows version installed.

In Windows Explorer or File Explorer, browse to C:\Datasets\Thursday\CM1560-L
Introduction to Visual Basic® for Applications for Autodesk® AutoCAD® and double-click
the EX5 - Procedures.txt file.

In Notepad, highlight all the code and right-click. Click Copy.

Switch back to the VBA Editor by selecting it from the Windows taskbar.

In the VBA IDE, Project Explorer, double-click basMain to open it in the code editor
window.

In the code editor window, select all of the code in the window and right-click. Click
Paste.

The procedures in the code editor window should now look like:

Public Sub DrawCircle()
Dim newCircle As AcadCircle
Dim centerPt As Variant
Dim radius As Double

AppActivate ThisDrawing.Application.Caption

Dim objutil As AcadUtility
Set objutil = ThisDrawing.Utility

centerPt = objuUtil.GetPoint(, vbLf + "Enter center point: ')

radius = objutil_GetDistance(centerPt, vbLf + "Enter radius: ')

Set newCircle = ThisDrawing.ModelSpace. _
AddCircle(centerPt, radius)

Dim objLayer As AcadLayer

Set objlLayer = MakeLayer('Objects-Circs', acMagenta)

newCircle.Layer = objlLayer.Name
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objutil _.Prompt vbLf + "Circle added to " + newCircle.Layer
End Sub

Public Function MakeLayer(Name As String, _
ACI As Integer) As AcadLayer
Dim newLayer As AcadLayer
Dim color As New AcadAcCmColor

color.Colorindex = ACI

Set newLayer = ThisDrawing.Layers.Add(Name)

newLayer .TrueColor = color

Set color = Nothing
Set MakeLayer = newLayer

End Function

7. On the menu bar, click File > Save.

8. Click in between the two statements that define the DrawCircle procedure.
9. On the menu bar, click Run > Run Sub/UserForm.

10. In AutoCAD, at the Enter center point: prompt, specify a point in the drawing
area. You can type a value or use the mouse to pick a point.

11. At the Enter radius: prompt, specify a point in the drawing area or enter a value.

The circle object is now drawn based on the center point and radius values you
specified, and is placed on the Objects-Circs layer.

12. On the ribbon, click Home tab > Layers panel > Layer drop-down list.
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You see the Objects-Circs layer has been added to the drawing.

tput  Plug-ins  Autodesk 360  Feature

Al A A=A

fv| ||Unsaved Layer State -

2| [ Ok WD =

LY B lo |2
Q ﬁ f . Objects-Circs

Selecting Objects
This exercise demonstrates how to select objects in a drawing and step through each of the
selected objects.

In the VBA IDE, Project Explorer, double-click basMain to open it in the code editor.
On the menu bar, click Insert » Procedure.

In the Add Procedure dialog box, Name text box, type SelectAndModifyObjects.
Set the type of the procedure to Sub and its scope to Public. Click OK.

In Windows Explorer or File Explorer, browse to C:\Datasets\Thursday\CM1560-L
Introduction to Visual Basic® for Applications for Autodesk® AutoCAD® and double-click
the EX6 - SelectAndModifyObjects.txt file.

In Notepad, highlight all the code and right-click. Click Copy.

Switch back to the VBA Editor by selecting it from the Windows taskbar.

Click in between the two statements that define the SelectAndModifyObjects
procedure and right-click. Click Paste.

The SelectAndModifyObjects procedure should now look like:
Public Sub SelectAndModifyObjects()
Dim sset As AcadSelectionSet

Dim ssets As AcadSelectionSets
Set ssets = ThisDrawing.SelectionSets

On Error Resume Next

Set sset = ssets.ltem("'AU2013_SS'™)
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IT Err_Number <> 0 Then

Set sset = ssets.Add('AU2013 SS'™)
Else

sset.Clear
End If

AppActivate ThisDrawing.Application.Caption

sset.SelectOnScreen

Dim ent As AcadEntity
Dim line As AcadLine

Dim circ As AcadCircle

For Each ent In sset
IT ent.ObjectName = "AcDbLine" Then

Set line = ent

line.EndPoint = _
ThisDrawing.Utility.PolarPoint(line.EndPoint, _
line.Angle, _
line.Length * 0.25)
Elself ent.ObjectName = "AcDbCircle™ Then

Set circ = ent

circ.radius = circ.radius * 1.25
End If

ent.Update
Next ent
End Sub

9. On the menu bar, click File > Save.
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10. Click in between the two statements that define the SelectAndModifyObjects
procedure.

11. On the menu bar, click Run » Run Sub/UserForm.
12. At the Select objects: prompt, select some objects in the drawing area.

If a line (AcDbLine) is selected, its length is changed by a factor of 25%; while if a circle
(AcDDbCircle) is selected, its radius is increased by 25%.

E7 Create a UserForm

This exercise explains how to create a UserForm that you can use to start a procedure and get
input from a user.

1. Inthe VBA IDE, on the menu bar, click Insert > UserForm.

E Microsoft Visual Basic for Applications - C\Datasets\T

(&l

Eile Edit View | Insert | Format Debug R

@ - = & Procedure... ]

Project - MyVBAProject |l§ UserForm |'_

G
E #  Module -

=-%% MyVBAProject (0 42} Class Module
£ AutoCAD Objec File

2. In the Project Explorer, double-click UserForm1 to make sure the form editor window is
opened and has focus.

E Microsoft Visual Basic for Applications - Ci\Datasets\Thursday\CM1560-L Introduction to Visual Basic® for Apg

Eile Edit View [nset Format Debug Bun  Tools Add-Ins  Window Help

BE-d

Project - MyVBAProject

=l=]]

E-8# MyVBAProject (C:\Datasets\Thursday
=5 AutoCAD Objects
¢ IE® ThisDrawing
(=145 Forms
i [E userForm1
(125 Modules

w2 basMain
q = T

Properties - UserForml

UserForm1 UserForm

Alphabetic | Categorized

UserForml -

BackColor [] aHs000000F& Toolbox (=]
BorderColor B =H300000128

BorderStyle 0 - fmBorderStyleMone Caontrals l

(Caption UserForm1

Cyde 0 - fmCydeAlForms k A abl i‘
DravwBuffer 32000 V&
Enabled True "

Font Tahoma Ij -
ForeColor W =H300000 125 4 A

Height 180 o = =
HelpContextlD a L
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—
On the Toolbox window, click the CommandButton control.

If the Toolbox window is not displayed, on the menu bar, click View > Toolbox.
Click and drag in the form editor window to create the control. Release the mouse button

when finished.

UzerForml

UzerForml
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5. Add two more CommandButtons to the UserForm.

UzerForml @

] CommandButton3

6. On the Toolbox window, click the Label control A and add two labels; one below each
of the two CommandButton controls that you added along the top of the UserForm.

UserForml

CommandButton1

CommandButton3
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7. On the Toolbox window, click the TextBox control ab| and add two text boxes; one
below each of the two Label controls that you added to the UserForm.

8. Click the title bar of the UserForm.

E Microsoft Visual Basic for Applications - C:\Datasets\Thursday\CM1560-L Introduction to Visual 7 E) for Apj

File Edit View Inset Format Debug Bun  Tools  Add-Ins  Window Help 8 |

& - ) b0 @ B Y (7] (¥4

Project - MyVBAProject x|

=l=1F]

=&} MyVBAProject (C:\Datasets\Thursday :
=5 AutoCAD Objects . CommandButton1

Al

B@ Forms

P frmMain
=25 Modules

4 | mn

Properties - frmMain

frmMain UserForm

0 - fmCydeAllFarms
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9. In the Properties Window, click in the
a. (Name) field and change the value to frmMain
b. Caption field and change the value to AU2013

10. Click in the form editor window.

k

11. On the Toolbox window, click the Select Objects tool.

12. In the form editor window, click the first CommandButton you added; labeled
CommandButtonl by default.

[ Au2013 ==

I ool Bl Bl e Gl oo Gl oo

CommandButton 1

13. In the Properties Window, click in the
a. (Name) field and change the value to cmdDrawCircle
b. Caption field and change the value to Draw Circle

14. Change the properties of the other controls you added to:

CommandButton2 CommandButton3
(Name): cmdSelectObjects (Name): cmdCreateLayer
Caption: Modify Objects Caption: Create Layer
Labell TextBox2

(Name): IblLayerName (Name): IblLayerACI
Caption: Name: Caption: ACI:

TextBox1 TextBox2

(Name): txtLayerName (Name): txtLayerACI
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19.

20.
21.
22.

CM1560-L: Introduction to Visual Basic® for Applications for Autodesk® AutoCAD®

The UserForm should now look like the following:

In the Project Explorer, double-click basMain to open it in the code editor window.

On the menu bar, click Insert > Procedure.
In the Add Procedure dialog box, Name text box, type ShowMain.
Set the type of the procedure to Sub and its scope to Public. Click OK.
Add the following statements in bold to the new ShowMain procedure:
Public Sub ShowMain()

Dim form As New frmMain

form.show

Set form = Nothing
End Sub

On the menu bar, click File » Save.
Click in between the two statements that define the ShowMain procedure.
On the menu bar, click Run » Run Sub/UserForm.

The UserForm is displayed in the AutoCAD application window.
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23. On the UserForm, interact with the controls you added and then click the Close button

E8

when you are done.

None of the buttons work with the exception of the Close button.

i N
AU2013 [
Diraw Circle
Modify Objects
Mame: ACL
Create Layer
L A

Adding Events to the Controls on the UserForm

This exercise explains how to add procedures that are executed when the user interacts with
the controls on the UserForm.

1.

In the VBA IDE, Project Explorer, double-click frmMain to make sure the form editor
window is opened and has focus.

Double-click the Draw Circle command button.
The code editor window for the UserForm opens and the following procedure is added.

Private Sub cmdDrawCircle_Click()

End Sub

Add the following statements to the new cmdDrawCircle_Click procedure:

Private Sub cmdDrawCircle Click()
Me.Hide
DrawCircle
Me .show

End Sub
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In the code editor window, along the top, click the Objects drop-down list and select
cmdSelectObjects.

— T Lo L - ey e E ey " aa — = L

- -
cmdDrawCircle H Click
[ (General)

cmdCreatelLayer
cmdDrawCircle

cmdSelectObjects

txtlayerACl
txtLayerlame
UserForm

] End Sub

~ e

In the Procedure drop-down list, select Click if it is not by default.

=i |

-~ Click [;]

BeforeDragOver F

BeforeDropOrPaste
Click
DbIClick
Enter
Error
Exit
KeyDown
— |KeyPress
KeylUp
MouzeDown
MouzeMove
Mouselp

The Click event for the cmdSelectObjects CommandButton is added to the code editor
window and is just like double-clicking on the control in the form editor window.

Private Sub cmdSelectObjects Click()

End Sub

Add the following statements to the new cmdSelectObjects_Click procedure:
Private Sub cmdSelectObjects Click()

Me.Hide

SelectAndModifyObjects

Me .show
End Sub

In the Project Explorer, double-click frmMain to make sure the form editor window is
opened and has focus.
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18.
19.
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Double-click the Create Layer command button.

Add the following statement to the new cmdCreatelLayer_Click procedure:
Private Sub cmdCreatelLayer Click()

MakeLayer txtLayerName.Text, Clnt(txtLayerACl._Text)
End Sub

On the menu bar, click File > Save.

In the Project Explorer, double-click basMain to open it in the code editor window.
Click between the two statements that define the ShowMain procedure.

On the menu bar, click Run > Run Sub/UserForm.

On the AU2013 dialog box, click Draw Circle and follow the prompts that are displayed.
Click Modify Objects and select some of the circles and lines in your drawing.

In the first text box, below the Name: label, type Doors.

In the second text box, below the ACI: label, type 1.

Click Create Layer and then click Close.

Switch to the AutoCAD application window. On the ribbon, click Home tab > Layers
panel » Layer drop-down list.

You see the Doors layer has been added to the drawing.

—

¥ | Unsaved Layer State - "
LY el o -
| 'Q 14 o o | A

¢ 1 o [l Objects-Circs
ﬂ g‘ ﬁ o [l Doors

34



CM1560-L: Introduction to Visual Basic® for Applications for Autodesk® AutoCAD®

E9 Stepping through Code and Adding Watches
This exercise explains how to use Breakpoints and Watches while a procedure is executing.

1. Inthe VBA IDE, right-click over a toolbar and click Debug if it is not checked.

AUU-INE  RInULW e

R

acis
Edit
Sub lic
ver Standard
UserForm
auh Customize... icl

1=

The following image shows the Debug toolbar.
W » n @O SE =& g s -

2. In the Project Explorer, right-click frmMain and click View Code.

3. Inthe code editor window, click in the Indicator Margin bar as shown in the following
image to add a breakpoint.

[ e o - . [ —r

cmdCreatelLayer + Click

Private Sub cmdCreatelayer Click()
MakelLayer txtLayerMName.Text, CInt(txtLayverACI.Text)
End Sub

Friwvate Sub cmdDrawCircle Click()
Me .Hide

” Me.show
End Sub

Friwvate Sub cmd3electCbjects Click()
Me .Hide
SelectindModifyChijects
Me .show

End Sub
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4. In the Project Explorer, double-click basMain to open it in the code editor window.

5. Scroll to the DrawCircle procedure.

6. Highlight the centerPt variable name in the DrawCircle procedure. Right-click and click
Add Watch.

= pbijUtil.GetPoint(, vbLf + "Enter center point: ")

# Cut
radius centerPt, wbLf + "Enter radius: ")

=2 Copy
Set ne [, Paste odelSpace.bhddCircle (centerPt, radius)
Dim oH ¥ List Properties/Methods
Set ol [} List Constants ects-Circs", acMagenta)
I Ci . L
REW-LE L QuickInfo e
ob3Uci % Parameter Info added to " + newCircle.Layer

End Sub | ., Complete Word
Public F Toggle b |B= String, ACI A= Integer) As Acadlaver

Dim neg eya .

=¢ Object Browser
Dim co o = T

Add Watch...
color. .
Definition
Set ng wvers.hdd (Hame)
newla
Y T~ Hide

S5et color = Nothing

7. Inthe Add Watch dialog box, in the Watch Type section, click Watch Expression. Click
OK.

[ N
Add Watch —3
E ion:
Kpression =
centerPt -_
Context
Procedure: [DrawCirde ,] m
Module: [Mndulel - ]

Project: MyVBAProject
Watch Type

(@ Watch Expression

] () Break When Value Is True

() Break When Value Changes
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The Watches window should open and show the centerPt variable you are now

watching.
Watches @

Expression “alue Type Context -

™ centerPt <0ut of context= Variant/Empty Module1 DrawCircle

8. Add watches for the radius, newCircle, and objLayer variables in the DrawCircle

procedure.
Watches @
Expression |".-"alue |T'_.r|:|e | Context -
&4 Radius <0ut of context= Empty Module! DrawCircle |
&d  centerPt <0ut of context= Variant/Empty Module1.DrawCircle =
&d newCircle <0ut of context= AcadCircle Medule1 DrawCircle
™ obilLayer <0ut of context= AcadlLaver Module1 DrawCircle :

9. Add a breakpoint to the following statement in the DrawCircle procedure.

Set objUtil = ThisDrawing.Utility

& centerPt = objUcil.GetPoint(, vbhLf + "Enter center point: ")

radius = objUcil.GetDistance (centerPt, vbLf + _
"TEnter radius: ")

10. Scroll to the SelectAndModi FyObjects procedure and highlight the variable name
ent.

11. Right-click and click Add Watch.
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12. In the Add Watch dialog box, in the Watch Type section, click Break When Value
Changes. Click OK.

o
Add Watch E
Expression: =
ent _
Context
Procedure: | SelectAndModifyObjects - =

Module: [Mﬂdel ~ ]

-

Project: MyVBAProject

Watch Type
() Watch Expression
\,. l () Break When Value Is True

(@ Break When Value Changes

L%

A

13. Scroll to and click between the two statements that define the ShowMain procedure.
14. On the menu bar, click Run » Run Sub/UserForm.

15. In the AU2013 dialog box, click Draw Circle.

The code editor window opens and the execution of the button’s Click event is
suspended.

cmdDrawCircle - Click

Friwvate Sub cmdCreatelayer Clicki)

MakelLaver txtLaverMName.Text, CInt(txtLaverACTI.Text)
End Sub

Friwvate Sub cmdDrawCircle Click()
Me.Hide

¢| [Joravcircie
Me .show

End Sub

16. On the Debug toolbar, click Step Into.
Execution advances to the DrawCircle procedure.

[(General) - DrawCircle

oy Public Sub DrawCircle ()
Dim newCircle A= AcadCircle
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17. On the Debug toolbar, click Continue.

Execution runs as normal until an error or the next breakpoint is encountered.

[ .CEIII:EI‘P'E = objUcil.FetPoint {, vbLf + "Enter center point: ")

radius = objUcil.GetDistance (centerPt, wbLf + _
"Enter radius: ")

||.;f|hI

18. On the Debug toolbar, click Step Into.
19. Switch to AutoCAD and specify a center point for the circle.

Execution returns to the code editor window.
20. In the Watches window, click the plus sign next to the centerPt variable.

The values of the centerPt are displayed.

Watches @
Expression “alue Type Context FS
) || CENMETRE Wariant/Double(l to 2 Module1.DrawCircle
centerPt{0) 12.6925158593357 Double Module1.DrawCircle |E|
centerPt1) 13.70700255976817 Double Module1.DrawCircle
centerPti2y 0 Double Module1.DrawCircle
ek newCircle Nnthinn AradCircle Mnduled DrawCircle ™

21. In the code editor window, right-click in front of the newCircle.Layer =
objLayer _Name statement. Click Run to Cursor.

22. Switch to AutoCAD and specify a radius for the circle.

Execution continues to the newCircle_Layer = objlLayer _Name statement.

Dim objLayer A=z AcadlLayer
Set objlLayer = MakelLayer ("OCbhjects-Circ", acHMagenta)
oy | newCircle.Layer = objLayer.Name

objUtil.Pronpt wblLf + "Circle added to " + newCircle.Layer
End Sub
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23. In the Watches window, click the plus sign next to the newCircle variable.

The properties of the AcadCircle object assigned to the newCircle variable are

displayed.
Watches @
Expression |‘-.-’a|u& |T'_.r|:re | Context -
&g Radius 6.26762520457534 Double Module1.DrawCircle

G [1] centerPt

— Area 135.508517659344
Center

— Circumferemn 41.26560619053885
— color acBylLayer

— Diameter 13.1352504099587
— EntityTransp "ByLayer”
Hyperlinks

— Layer "0

VariantDouble(d to 2 Module1.DrawCircle
s
Module1.DrawCircle
VariantDouble(d to 2 Module1.DrawCircle
Module1.DrawCircle
Module1.DrawCircle
Module1.DrawCircle
Module1.DrawCircle
lacadHyperlinks/laca Module1.DrawCircle
Module1.DrawCircle -

Double

Double

ACAD_COLOR

Double
String

String

24. On the Debug toolbar, click Cont

inue.

Execution runs as normal and the AU2013 dialog box is displayed.

25. In the AU2013 dialog box, click Modify Objects.

26. At the Select objects: prompt, select some circle and/or line objects in the drawing

and press Enter.

Execution continues until the value of the ent variable is changed as indicated by the

Watch you set earlier in step 11.

For Each ent In sset
(=53 If ent.ObjectName
Set linme = ent

= "AcDbLine™ Then

line.endPoint = _
ThisDrawing.Utility.PolarPoint (line.endPoint,

27. In the Watches window, review the value assigned to the ent variable.

28. On the Debug toolbar, click Cont

inue.

Execution continues until the value of the ent variable changes again.

29. Step through the code using the

Step Into

or Step Out

(.3

buttons, and keep

clicking Continue P unti you are returned to the AU2013 dialog box.
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30.

31.

32.

33.

34. On the Debug toolbar, click Reset.
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In the AU2013 dialog box, clear both text boxes if they contain a value, and click Create
Layer.

The Microsoft Visual Basic dialog box is displayed.

Microsoft Visual Basic

Run-time error '13"

Type mismatch

Continue [ End ] [ Debug ] [ Help ]

L A

On the Microsoft Visual Basic dialog box, click Debug.

Execution is suspended and you are sent to the code editor window for the frmMain
UserForm.

Private Subk cmdCreatelayer Click()
o | MakelLayer txtLayerWame.Text, CInt (txtLayerACT.Text)
End Sub

Position the cursor over the text txtLayerName.Text.

A tooltip with the statement’s current value is displayed. While a blank text string will be
a problem later in the MakeLayer function that is not the cause of the problem.

Private Subk cmdCreatelayer Click
o | Makelayer txtLayerName.Text, C

End Sub [thyHNam&Tedz""i

Position the cursor over the text CInt.

A tooltip with the statement’s current value is displayed. Notice the tooltip contains the
text <Type mismatch> which matches the error message previously displayed. This is
caused because CInt cannot convert an empty text string to a number value.

zatelayer Click()
verName .Text, CInt (txtLayverACI.Text)

_[ Clnt{ttlayerACLText) = < Type mismatch> i

d
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40.
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42.
43.

44,
45.
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In the Project Explorer, right-click frmMain and click View Code.
In the code editor window, change cmdCreatelLayer_Click procedure so it looks like
the following:
Private Sub cmdCreatelLayer Click()
IT txtLayerName.Text <> """ And txtLayerACl.Text <> """ Then
MakeLayer txtLayerName.Text, Clnt(txtLayerACl.Text)
Else
MsgBox '‘Missing name or color for layer."
End If
End Sub

On the menu bar, click File > Save.

In the Project Explorer, double-click basMain to open it in the code editor window.
Scroll to and click between the two statements that define the ShowMain procedure.
On the menu bar, click Run » Run Sub/UserForm.

In the AU2013 dialog box, leave both text boxes empty and click Create Layer.

( My Tools Iﬁ )

AutoCAD P

’__ Missing narme or color for layer, -
------------

L A

In the message box, click OK to continue.

In the AU2013 dialog box, type a name and color for the layer and then click Create
Layer.

Close the dialog box when done.

Switch to the AutoCAD application window. On the ribbon, click Home tab > Layers
panel > Layer drop-down list.
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E10 Formatting Controls on a UserForm
This exercise explains how to use some of the UserForm formatting tools.

1. Inthe VBA IDE, Project Explorer, double-click frmMain to view it in the form editor
window.

Draw Circle

2. In the form editor window, select the Draw Circle button.

3. Inthe Properties window, change the following properties for the button:

e Height = 40
o Left=6
e Top=6
e Width =110

[ Au2013 =

Draw Cirde

4. In the form editor window, select the Modify Objects button.
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5. In the Properties window, change the following properties for the button:
o Height =40
o Left=120
o Top=6
e Width =110

Draw Circle Modify Objects

6. Along the left side of the UserForm, select the text box.

7. Hold down the Ctrl key. Select the label and the Draw Circle button; in that order.

[ Au2013 ==

Draw Circle

8. On the menu bar, click Format > Align > Lefts.

splications - CA\Datasets\Thursday\CM1360-L Introduction

t | Format | Debug Run  Tools  Add-Ins  Window
S —
Make Same Size » ‘ & Centers F

9. Along the right side of the UserForm, select the Create Layer button.
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10. Hold down the Citrl key. Select the text box, label, and the Modify Objects button; in that
order.

Muodify Objects

..................... Create Layer

11. On the menu bar, click Format > Align > Lefts.

12. Click the UserForm and then select the Create Layer button. Hold down the Ctrl key and
select Modify Objects button.

AU2013 5]

Modify Objects

Create Layer

13. On the menu bar, click Format » Make Same Size » Both.

plications - C\Datasets\Thursday\CM1580-L Introducti

t Fgrmatigebug Bun Tools Add-Ins  Winc

Align 3 Eﬁ: fl* "';_'t‘r' o @
| Make Same Size  » | =} Width -
Size to Fit 4] Height 5

s L Size to Grid {51 Both

Horizontal Spacing »
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14. Click the UserForm, and then select the Create Layer button. Drag the Create Layer
button up/down as needed.

15. Align the labels and text boxes using the tools on the Format menu.

The end result should be a cleaner looking UserForm. Yours does not need to look like
the following in the end, but gives you an idea what you might want to do.

Create Layer

16. In the VBA IDE, on the menu bar, click File » Save.

E11 Exporting AutoCAD Information to a Spreadsheet

This exercise explains how to create a reference to Microsoft Excel and write out information to
a spreadsheet. This could be a great way to do estimating or generate information from a
drawing for a bid package.

1. Inthe VBA IDE, Project Explorer, double-click frmMain to view it in the form editor
window.

2. Add a new CommandButton to the UserForm, and then change the following properties
for the button:
¢ (Name) = cmdExport
e Caption = Export

3. Double-click the button to open the code editor window.

4. On the menu bar, click Tools » References.
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5. In the References dialog box, scroll down and locate Microsoft Excel 14.0 Object Library.
Click the library reference and then click OK.

-

References - MyVBAProject

Available References: a

Microsoft Development Environment YC++ Project 5 - Cancel
Microsoft Development Environment VC++ Project S
Microsoft Development Environment VC++ Project S
Microsoft Development Environment VC++ Project 5 Browse...
Microsoft Development Environment VC++ Project S
Microsoft Development Environment VC++ Project S ﬂ
Microsoft Direct¥ Transforms Core Type Library |
Microsoft Directy Transforms Image Transforms Type — | Priority
Microsoft Disk Quota 1.0 Help
Microsoft OTS Runtime 1.0 ﬂ
v

Microsoft Fax Service Extended COM Type Library
Microsoft Fax Service Extended COM Type Library

Mirrnsnft Feeds 2.0 Ohiect |ibrary
1| 1] 3

v Itkg

Microsoft Excel 14.0 Object Library

Location:  C:\Program Files\Microsoft OfficeOffice 14'EXCEL.EXE
Language: Standard

L A

6. In Windows Explorer or File Explorer, browse to C:\Datasets\Thursday\CM1560-L
Introduction to Visual Basic® for Applications for Autodesk® AutoCAD® and double-click
the EX11 — Export.txt file.

7. In Notepad, highlight all the code and right-click. Click Copy.

8. Switch back to the VBA IDE. Click between the two statements that define the
cmdExport_Click procedure. Right-click and click Paste to add the copied code.

Private Sub cmdExport Click()
" Create a reference to a new Excel application

Dim execl As New Excel_Application

execl .Visible = True

" Create a new workbook

Dim workbk As Excel .workbook

Set workbk = execl._workbooks.Add

" Get the first worksheet
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Dim worksht As Excel .worksheet
Set worksht = workbk.worksheets(1)

" Add Intro Text to cell Al

Dim workshtRange As Excel .Range

Set workshtRange = worksht.Range('Al1')

workshtRange.Value = "AU2013 - Introduction to Visual Basic®
for Applications for Autodesk® AutoCAD®

" Add column headers
worksht.Range(*'A2™) .Value
worksht.Range(''B2") .Value

"Handle"

"Radius"

" Step through each of the objects in the current space
" and extract only the circles

Dim ent As AcadEntity

Dim circ As AcadCircle

Dim row As Integer

row = 3

For Each ent In ThisDrawing.ModelSpace
IT ent.ObjectName = "AcDbCircle"™ Then
Set circ = ent

worksht._Range("'A" & CInt(row)).Value = """ & circ.Handle

worksht.Range("'B" & Cint(row)).Value CStr(circ.radius)

row = row + 1

End If
Next ent
End Sub
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9. On the menu bar, click File > Save.

10. In the Project Explorer, double-click basMain to open it in the code editor window.

11. Scroll to and click between the two statements that define the ShowMain procedure.

12. On the menu bar, click Run » Run Sub/UserForm.

13. In the AU2013 dialog box, click Export.

The following image provides an idea what the output should look like in Microsoft Excel.

11

14. Close Microsoft Excel and discard the changes made.

15. Close the AU2013 dialog box.
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