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Learning Objectives
Learn how to configure and use Desktop Connector for better cloud connectivity.
Learn how to create and maintain reference relationships for AutoCAD drawings through Autodesk Docs.
Learn how to use the file locking feature for better collaboration during project lifecycles.
[bookmark: OLE_LINK12]Learn how to use reference explorer on Autodesk Construction Cloud.





Description

In this class, we'll introduce you to connected workflows between AutoCAD software and Autodesk Construction Cloud. You'll see a detailed walk-through on reference drawings and their relationships within Autodesk Docs. Learn how users can maximize the full potential of Desktop Connector to validate reference files, maintain associativity, and establish versioning of drawing files in Autodesk Docs. Then, we'll introduce the integration of the file locking feature into AutoCAD and see its benefits while sharing drawings through projects in Autodesk Construction Cloud. 
We'll share some best practices in terms of handling drawing file operations within AutoCAD for cloud-based storage. Finally, we'll wrap up with some key tools that will enable you to collaborate efficiently and increase productivity through Autodesk Cloud Services.



Speaker(s)

Vinod Kumar Balasubramanian is our Principal Specialist for AutoCAD & Toolsets in Customer Success Organization. He handles Strategic Prioritization of escalations through Customer First approach, drives adoption through Stake holder management, provides Insights to Engineering on Product Road Map and Feature improvements. His key responsibility is to remove customer barriers and enhance Product Utilization through qualitative & quantitative analysis of customer issues. His overall focus is on improving Product & Customer Experience for all our customers using AutoCAD Family Products.

Elliot Rosenfeld is our Principal Specialist for Infrastructure. He has been at Autodesk for 8 years, first working as a Sr. Content Experience Designer before joining the Customer Success Organization. Based out of California, Elliott's top priority at Autodesk is to report strategic insights to our product leadership about barriers that prevent adoption and expansion for our customers. In his free time, Elliott likes to be outside, adventuring, as shown in this photo from Blue Glacier, a large glacier located to the north of Mount Olympus in the Olympic Mountains of Washington.

Bastien Mazeran is our Principal Specialist for the Forge API / Cloud portfolio in our Customer Success Organization. He is responsible for delivering product insights to the Product & Engineering team and strives to help Engineering strategize product roadmap investments based on customer experiences and mission-critical escalations. He has been with Autodesk for over 9 years in various support roles and is currently based in Barcelona, Spain.
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Learn how to configure and use Desktop Connector for better cloud connectivity.

Desktop Connector is a desktop service that integrates Autodesk Docs with your desktop folder and file structure for easy file management. A local folder that mirrors the structure of Autodesk Docs projects and folders is made available in Windows File Explorer. While the structure is replicated in File Explorer, the files are not downloaded until they are opened.

How to access Desktop Connector

Desktop Connector is accessed through the Windows System Tray. 
Simply locate the Desktop Connector [image: ] icon and right-click on it. Select Help > About to find the version of the installed application.

[image: ]

Before you can see the Autodesk Docs cloud files, you need to sign-in.

From the Windows System tray, right-click on the Desktop Connector [image: ]icon and select Sign In. On the Autodesk Sign-In screen, enter your Autodesk credentials and click Sign In. 

The Autodesk Docs drive is created and associated with your Autodesk credentials.

[image: Graphical user interface, text, application

Description automatically generated]

Any hubs inside the Autodesk Docs drive will be marked with an [image: ]icon.
You can find the Desktop Connector documentation here.

Collecting the Desktop Connector Diagnostic Logs

Desktop Connector gathers diagnostics logs to help you troubleshoot Desktop Connector events. Although the application gathers your data, it does not share your data with anyone.

In this section, you will learn how to set verbose logging and capture a verbose diagnostics log.


I. From the Windows System tray, press SHIFT key and right-click on the Desktop Connector [image: ] icon
II. Expand Help > Diagnostics Mode
III. Set Logging to Verbose

[image: ]

IV. Save Changes
V. Launch AutoCAD 2023 Update 1
VI. File > Open
VII. Select a DWG file in an Autodesk Docs folder
VIII. Close AutoCAD 
IX. Verify in File Explorer that the DWG file icon status changed to [image: ] Synced

X. Save From the Windows System tray, right-click again on the Desktop   Connector icon [image: ]

XI. Expand Help > Diagnostics Logs

     [image: ]

XII. Click on Open File Location
XIII. You will find a compressed zip file in File Explorer that can be sent to Autodesk Support for further analysis

Learn how to create and maintain reference relationships for AutoCAD drawings through Autodesk Docs.

I. [bookmark: OLE_LINK16]Login to https://acc.autodesk.com/ using the credentials given to you during the AU Class
II. You will have access to project named – Connect the Dots (AU 2022)
III. Switch to Docs environment and Select files


[image: Graphical user interface, text, application

Description automatically generated]                            [image: Graphical user interface, application

Description automatically generated]


IV. Go to Project files > Right Click to select Add Sub folders > Create a new folder called Xrefs
[image: Graphical user interface, text, application, email

Description automatically generated]
V. Under XRefs folder, create two sub folders – Simple, Related & Nested
VI. Switch back to Autodesk Docs drive on Windows Explorer
VII. [bookmark: OLE_LINK1]Check if those folders were created in your local cache
[image: Graphical user interface, text, application

Description automatically generated]
[bookmark: OLE_LINK2]
[bookmark: OLE_LINK4]Exercise 1 : This exercise shows you how Desktop Connector will bring all relationship files & folder structure with the Master drawing using related data folder.


[bookmark: OLE_LINK5]Go to desktop, Check folder Demo Dataset.

I. In Demo Dataset, Go to folder XRefs > Related > Master
II. Launch AutoCAD 2023
III. Open drawing named Master.dwg inside Master folder
IV. In AutoCAD Command line, type “XREF” and press Enter
V. External reference Manager Palette will open
VI. Check the file structure to see if both files are referenced as shown below.
VII. Close Master.dwg

                           [image: Graphical user interface, application

Description automatically generated]                                           

VIII. [bookmark: OLE_LINK6]Switch Demo Dataset on Windows Explorer. Navigate to XRefs > Related > Master
IX. Drag and drop Master.dwg into the following folder in Docs C:\Users\username\ACCDocs\Connect-The-Dots-AU-2022\Connect the Dots (AU 2022)\Project Files\XRefs\Related
X. Master.dwg should be copied to the above root folder.
XI. Additional folder named Master will be created in the same folder structure
        [image: Graphical user interface, application

Description automatically generated]

XII. Inside Master Folder, there will be a folder named “Related data”
[image: Graphical user interface, application
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XIII. Inside Related data folder, there will be sub folders directing the path to Reference.dwg.

[bookmark: OLE_LINK9]Exercise 2 : This exercise shows you how to eliminate creation of related data folder and maintain folder structure same as Windows explorer for the references in Docs.


[bookmark: OLE_LINK10]Go to desktop, Check folder Demo Dataset.

I. In Demo Dataset, Go to folder XRefs > Simple 
II. Launch AutoCAD 2023
III. Open drawing named Master.dwg 
IV. In AutoCAD Command line, type “XREF” and press Enter
V. External reference Manager Palette will open
VI. Check if Reference.dwg is referenced to Master.dwg
VII. Save & Close Master.dwg
VIII. [bookmark: OLE_LINK7][bookmark: OLE_LINK8]Switch Demo Dataset on Windows Explorer. Navigate to folder XRefs > Simple > Master
IX. Drag and drop Master.dwg into the following folder in Docs C:\Users\username\ACCDocs\Connect-The-Dots-AU-2022\Connect the Dots (AU 2022)\Project Files\XRefs\Simple
X. Master.dwg should be copied to the root folder.
XI. Additional folder named Reference will be created in the same folder structure.
XII. Open Reference folder to see the Reference.dwg


Exercise 3 : Concurrent editing of reference drawings and how AutoCAD & Autodesk Docs alerts users on the changes made in the drawing. This is a two-user scenario – User A & B will be used as reference names in the workflow.


      
Go to desktop, Check folder Demo Dataset.

I. In Demo Dataset, Go to folder XRefs > Simple.
II. Both User A & B to Launch AutoCAD 2023.
III. User A to open Master.dwg on their machine.
IV. User B to open Reference.dwg on their machine.
V. User B to add a line or text on Reference.dwg.
VI. Save and Close drawing.
VII. Go to Desktop Connector on System tray.
VIII. Open Pending actions in Desktop Connector to see if everything is synced properly.
IX. User A to open https://acc.autodesk.com/ in the browser.
X. Navigate to Project > Connect the Dots (AU 2022) > XRefs > Simple.
XI. Open the Master.dwg in Docs Viewer.
XII. User A should see this warning message below on their Docs Viewer.

  [image: ]

XIII. User A should open the Master.dwg and Reference.dwg in AutoCAD.
XIV. AutoCAD provides an alert that reference drawing in Master needs to be reloaded.

    [image: ]

XV. AutoCAD provides an alert that reference drawing in Master needs to be reloaded.
XVI. Reload Reference.dwg on Master.dwg.
XVII. Save and close drawing.
XVIII. User A to open https://acc.autodesk.com/ in the browser.
XIX. Navigate to Project > Connect the Dots (AU 2022) > XRefs > Simple.
XX. Open the Master.dwg in Docs Viewer.
XXI. Master.dwg should be updated with the changes made to Reference.dwg.




Learn how to use the file locking feature for better collaboration during project lifecycles.

[bookmark: OLE_LINK13]Exercise 4 : This exercise shows how to observe a simple lock being placed and warning alert from AutoCAD to users when they try to concurrently edit a drawing file from Autodesk Docs.


Go to desktop, Check folder Demo Dataset.

I. [bookmark: OLE_LINK14]In Demo Dataset, go to folder named File locking
II. Both User A & B to Launch AutoCAD 2023
III. User A to open AU Lock1.dwg on their machine
IV. User B to open AU Lock2.dwg on their machine
V. [bookmark: OLE_LINK11]User A tries to open AU Lock2.dwg

Following warning message should show up for User A. 
User A to Accept and open drawing
[image: Graphical user interface, text, application

Description automatically generated]

VI. User A also observes a lock icon next to AU Lock2.dwg.

[image: Graphical user interface, application

Description automatically generated]


 Exercise 5 : This exercise shows how you can bridge a folder from one Project with another in Autodesk Docs.

I. Login to https://acc.autodesk.com/ using the credentials given to you during the AU Class.
II. Create two new projects name Bridge 1 & Bridge 2 in Autodesk Docs.
III. Click Projects from the left navigation to open the Projects tool.

IV. Click Create Project
V. [bookmark: OLE_LINK17]Enter the project details in the Create project dialog box as shown below

      [image: Graphical user interface, application

Description automatically generated]

VI. Repeat the same to create the second project named Bridge 2.
VII. Assign Products access permission to Autodesk Docs for both projects.

      [image: Graphical user interface, text, application, chat or text message

Description automatically generated]
     
VIII. Create a sub folder in Project Bridge 1 as Bridge 1
IX. Create a sub folder in Project Bridge 2 as Bridge 2
X. Go to Demo Dataset in Windows Explorer, go to folder named Bridge
XI. [bookmark: OLE_LINK15]Drag and drop drawings from folder Bridge 1 through Desktop Connector to Autodesk Project named Bridge 1
XII. Drag and drop drawings from folder Bridge 2 through Desktop Connector to Autodesk Project named Bridge 2
XIII. In the browser, access Project Bridge 1 and select the sub folder Bridge 1 to share with Project Bridge 2
XIV. [bookmark: OLE_LINK18]Configure the following settings in using share dialog to create the Bridge between projects.

[image: Graphical user interface, text, application
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XV. [bookmark: OLE_LINK19]In the browser, switch to Project Bridge 2 to see the folder Bridge 1 linked to this project.

        [image: Graphical user interface, application
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XVI. In the browser, switch to Project Bridge 2 to see the folder Bridge 1 linked to this project.
XVII. This will create a link between files in both projects.


Learn how to use Reference Explorer in Desktop Connector to identify drawing issues before uploading to Autodesk Docs


Reference Explorer is a utility that is installed with Desktop Connector that you can use to visualize all files in a dataset as well as the relationships between them.

Its primary use is as a pre-check before adding data to Autodesk Docs.

1. Better understand the size and scope of the dataset before uploading
2. Visualize file relationships using pan and zoom in different graph views
3. Identify files in the dataset that may be located on a network share or only accessible to you locally
4. Identify files that are missing or contain circular references

You can then decide to correct the issue(s) in the dataset before uploading to Autodesk Docs.

How to access Reference Explorer

Reference Explorer is accessed through the Windows System Tray. 
Simply locate the Desktop Connector [image: ] icon and right-click on it.

[image: ]


Select Reference Explorer to launch the utility.

[image: ]

You can now drag and drop your main drawing into the utility from a local folder or from an Autodesk Docs folder (in the latter case, you will need to have the files synced first) to visualize the relationships.

Exercise 6 : This exercise shows how to detect missing references, circular references and read the reference type (XREF, DREF or Overlay).

I. Launch Reference Explorer
II. Launch Windows File Explorer and navigate to \Autodesk Docs\{Hub Name}\projects\XRefs\Nested
III. Sync all files and subfolders in that directory
IV. Drag and drop Shaft1.dwg into Reference Explorer
V. In List View, notice the two missing references
                 [image: ]
VI. Select Tree View and notice the nested relationships
                [image: ]
VII. Select Graph View and notice the circular reference between Shaft4.dwg and Shaft1.dwg, then observe the Overlay reference between Shaft1.dwg and Shaft6.dwg
[image: ]
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