
 
 

 

 

Page 1 

AS502948 

Visualization in Minutes: Exploring Twinmotion’s Bag 

of Tricks 

Sam Anderson 

Epic Games 

 

 

 

Learning Objectives  

 
• Learn how to use Datasmith Direct Link to streamline Revit visualization workflows 

• Enhance realism with assets from Twinmotion, Quixel, and Sketchfab 

• Improve stakeholder communication with storytelling techniques 

• Learn when to bring designs into Unreal Engine 5 for bespoke experiences 

•  

Description 

Instant feedback transforms ideas—especially during the design stage. But only when it’s 
accessible. In this class, you’ll learn how to elevate Revit models in a matter of minutes, using 
an ecosystem that’s surprisingly simple. Twinmotion for real-time visualization, Sketchfab/Quixel 
for assets, Unreal Engine for when you want to run wild—see how each element comes 
together to help designers explore more “what ifs?”, without compromising intent or quality. 
 

Speaker(s) 

Sam Anderson 

Technical Marketing Manager, Epic Games 

 

Sam Anderson is a technical marketing manager at Epic Games developing visual and technical 
content in Unreal Engine and Twinmotion. A designer and 3D artist based in New York City and 
Los Angeles, Sam has a focus in real-time rendering. Previously, she was a visualization 
specialist at SHoP Architects where she focused on research and development, promoting the 
use of real-time technology to improve design processes.  
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Introduction 

 

What is Twinmotion? 
Twinmotion is an intuitive, real-time, immersive 3D visualization tool. With an easy-to-use icon-
driven interface and the power of Unreal Engine running under the hood, it empowers 
architecture, construction, urban planning, and landscaping professionals to produce high-
quality visualizations and easily share them using Twinmotion Cloud. 
 

Agenda 
This example will walk through how to bring a BIM model intoTwinmotion and later develop that 
model further in Unreal Engine if desired. For more information on the steps featured in this 
example, please refer to the Twinmotion documentation resource online. 
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Use the Datasmith Direct Link to streamline Revit visualization workflows 
 

Download plugin 
The first step to getting your BIM models into Twinmotion is to download the Datasmith plugin 
by visiting Twinmotion.com/plugins. Choose your modeling solution and select Download. This 
handout will specifically highlight Revit, however similar workflows apply to other modeling tools. 
 

 
 
Once the plugin is downloaded, restart Revit. The user interface will have a new toolbar named 
Datasmith. 
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Toolbar 
The new toolbar will have five icons. Select Settings to take a look at the Datasmith export 
options. A new feature of the Datasmith plugin for Revit is the ability to change the Level of 
Tessellation here. By default this is set at 8. If you wanted to optimize your model before taking 
it into Twinmotion, you could lower this number. For instance, if you need high-fidelity geometry 
you could keep this number at 8 or increase it. However, if high-fidelity geometry is not 
important, you can lower the number which will optimize the building before bringing it in. Test 
out which tessellation number works best for your model at this point in the project. 
 

 

Metadata 
In the same Datasmith Export Settings window, there will be an option for editing the 
metadata information that is brought in. You may see a few groups automatically register. You 
can curate this list for your needs by selecting a group and hitting Remove Selected or hit Add 
Group for additional metadata options. 

 

Messages 
Left of the Settings tab is the Messages icon. Text displaying errors or missing texture 
information will appear here if applicable during the export process. 
 

Standalone Datasmith 
Left of the Messages there are two separate sections of Datasmith file functions, File Export 
and Direct Link. The File Export option here is going to export a stand-alone file that can then 
be imported into Twinmotion. This can be helpful if the file is sent to another agency or if the 
user developing the project in Twinmotion does not have access to the original modeling 
program. 
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Establish connection 
The Direct Link icons are going to synchronize the Revit model with Twinmotion. To do this, 
first establish the connection inside of Twinmotion. 
 

Open the Epic Games launcher to download or launch Twinmotion. This handout features 
Twinmotion 2022.2. If this is your first experience in Twinmotion, take some time to explore the 
user interface. At first launch, a bar at the top of the screen will have tips for navigating the 
scene. 
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On the left is the Library with access to assets and tools. On the right-hand side is the Scene 
graph where the project assets will be displayed. The bottom of the screen has the import 
options, tools for developing the scene, as well as media export options. 
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To establish the Datasmith Direct Link connection, select the Import icon on the left-hand side 
of the dock and hit the + button. Here you have four import options: GEOMETRY, DIRECT 
LINK, LANDSCAPE, and POINT CLOUDS. With the first GEOMETRY option, you can import 
many different file formats including FBX, OBJ, or standalone Datasmith files. For this example, 
we will use the DIRECT LINK option to connect to the Revit Datasmith file. If the Revit model is 
open on the computer, Twinmotion will recognize the Revit file as the source file. Select Import. 
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Import settings 
A window will pop up with additional import settings to control. The default settings work well for 
beginners and enable experienced users to better optimize the imported model. For example, 
users can Collapse by material, Collapse all or Keep hierarchy of the Revit project structure. 
For this example, I will select Keep hierarchy to demonstrate how Revit model structures are 
imported. 
 

 
 

Sync project 
After selecting the Import button, a new icon will appear in the dock with the name of the Revit 
model. By clicking the … ellipses on top of the icon, you will see the actions that are available 
as the project progresses. To bring the project into the viewport and Scene graph, the model 
will need to be synchronized from Revit.  

 
At this point, switch over to the Revit model and hit Synchronize. A green update bar will pop 
up in the bottom left-hand corner showing the status of the export process. Now jump back into 
Twinmotion. A window will pop up with a status bar of the Direct Link import process. Import 
times will be dependent on the size of your project. The Revit project will now be visible in the 
viewport and Scene graph. If it is not visible, select an item from the Scene graph and hit F on 
your keyboard to zoom into the selected item. If any changes are made in Revit, hit the 
Synchronize button again to update Twinmotion with the Revit changes. 
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Enhance realism with assets from Twinmotion, Quixel, and Sketchfab 

 

Apply materials 
If the Revit model had materials applied, those materials will be present on the model inside 
Twinmotion. To edit those materials, select the Material picker on the middle toolbar on the 
dock. The material will appear in the material graph. Here you have the ability to change the 
color, scale, bump, and more. If you’d like to create your own material, select the icon on the 
bottom right-hand side of the material graph to toggle the grid layout to see multiple thumbnails. 
Select the + button. Here you can add in custom images and set up your material as desired. If 
you would like to use pre-made native Twinmotion materials, you can do so by going up to the 
left-hand side, opening up the Library tab, and browsing the Materials section. 
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Quixel Megascans Surfaces 
Additional materials assets are available through the Quixel Megascans integration inside 
Twinmotion. Quixel Megascans is an immense scan library with thousands of 3D assets, tileable 
surfaces, vegetation, decals, and more. With your Epic Games account, you have access to 
Megascans assets in Twinmotion’s Library. Select the Quixel Megascans icon in the Library. 
For material options, browse the Surfaces section for scanned textures. To use the assets in 
your project, hit the downward arrow in the top right-hand corner of the asset thumbnail. If this is 
grayed out, it is informing you that Twinmotion is not successfully connected to your Epic 
Games account. To sign in, go to File > Sign into Epic Games and follow the proceeding 
steps. Once signed in, the arrow will light up when you hover over it. After the download of the 
asset completes, you can drag and drop the asset onto the geometry in the viewport. 
 

 

 

Landscape tools 
To further develop your project, you have the option to apply trees and vegetation to your 
model. The tools can be found by clicking the Context icon on the bottom left-hand side of the 
dock. 
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Here you will have access to PATHS, VEGETATION PAINT, VEGETATION SCATTER, and 
URBAN. This point of the example will cover VEGETATION PAINT and VEGETATION 
SCATTER. Select the VEGETATION SCATTER paint bucket. The library will automatically 
appear with access to various grasses. Select a few you’d like to use and drag and drop them 
into the dock. Select those assets inside of the dock and hit the + button in the navigation tools 
on the dock.  Now, select the geometry you would like to apply grass to. Each click will increase 
the density of the grass. After it is applied, you can make changes to the grass by selecting the 
SETTINGS tab. 
 

 

 

Grass preferences settings 
When you are adding grass into the scene, you may notice the grass fades away as the camera 
moves. This is due to a performance setting in Twinmotion preferences. To access this, go to 
Edit > Preferences > SETTINGS > Grass fading and select Near, Medium, or Far. Near will 
have better performance and Far will display more grass in your scene. Regardless of the 
setting chosen here, all grass will render and be present in media output from Twinmotion. 
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Now use VEGETATION PAINT to add trees using a similar workflow to the scatter tool. Instead 
of selecting the + button, you can use the paint brush to paint areas of the geometry where the 
selected trees will be applied. In the SETTINGS tab, you can change the size and color tint of 
the trees. 
 

 

 

Quixel Megascans 3D assets 
To further add 3D elements to your model you can use native Twinmotion objects in the library 
or utilize some of the new integrations such as the Quixel Megascans library referred to earlier 
in this example. Browse the Library and import flowers, food, props and more. The download 
and drag and drop workflow will be similar to the process of bringing Quixel Surfaces into the 
model. 
 

 
 
  



 
 

 

 

Page 13 

Sketchfab integration 
To expand library options even further, users with Epic Games accounts also have access to 
Sketchfab libraries. Sketchfab is another tool within the Epic ecosystem. Sketchfab is a platform 
for creators to share and embed 3D models anywhere online. Browse the Sketchfab libraries to 
add assets as you wish. If you click on an asset, it will give you access to its license information, 
size, and name of the creator. You can also pull up the Sketchfab browser to get more 
information. The workflow for downloading and bringing the assets into the project is similar to 
the Quixel Megascans process. 
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glTF for Sketchfab 
If you would like to import assets you have previously downloaded on Sketchfab, you can do so 
by exporting the asset as a glTF on your Sketchfab website and importing the glTF into 
Twinmotion. 
 

Sketchfab edits 
Select your asset of choice, download and drop it into the scene. If you’d like to edit any of the 
materials, you can do so by clicking the Material picker, selecting the geometry and making 
changes in the dock below. 
 

Collision mesh and placement 
When placing assets you may have noticed the assets snap to a plane near the cursor. As you 
move and curate the entourage in your scene, there may be instances where you would like to 
have the asset aligned to a wall or floor. With Twinmotion 2022.2, there are new tools that can 
assist in geometry placement. These tools are the Move with collision and Gravity tool that 
are located in the navigation tools in the middle-top area of the dock. 
 

 

 

Gravity tool 
To test out these tools, first select an asset and move it above the ground floor. Now select the 
Move with collision icon. It will be highlighted and let you know it is applying convex collision 
meshes to the objects in your scene. Now as you move the asset down or to the side, the object 
will stop when it collides with another object. To test the Gravity tool, move it above the ground 
floor once again and then select the Gravity icon. The asset will fall to the ground. 
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Improve stakeholder communication with storytelling techniques 
 

Animated objects 
Now that materials are applied and objects are placed, you can start to layer in animated 
elements into your scene. This part of the example will cover animated characters, animated 
paths, and animated sun positions. 
 

Groups 
To explore the characters, go to Library > Characters. There you will find options for Posed 
humans which is great for high-fidelity characters and Cutout which is nice when low-poly 
characters are needed. For an animated experience, use Animated humans or Groups. 
Choose a group to drag and drop into the scene. 
 

 
 
You can click on any individual in the group to change the character’s Cloth color, Pose, or 
Animation. 
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Paths 
If you’d like to have characters walk along a pathway, you can use Twinmotion’s Path tools in 
the Context section of the dock. Go to Context > Path to view path options. 
 

 
 

Select CHARACTER PATH and select the pen icon to start placing a spline on the sidewalk. To 
end the spline creation, hit the right mouse button. Now you can change the settings of this path 
to meet your needs. 

 

 

You can apply this path workflow to vehicles, bikes, or customize your own with your object of 
choice. 

 

Still image media 
Twinmotion offers a variety of media outputs to capture and share animated and still elements. 
This part of the example will cover working with still media, videos, and Twinmotion Cloud. First 
explore the still image media option by selecting Media > Image in the dock. Hit the + button to 
save an image based on your viewport. You can continue to navigate around the scene and 
select the thumbnail of the image to jump back to the saved viewport. Changes to the image 
camera position can be made by selecting the refresh button viewable when you hover your 
mouse above the thumbnail. 
 

 
 
Create as many images as you like. For each image, you will be able to save individual settings. 
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Season set up 
To further explore specific settings for each image, this example will cover the weather features 
inside Twinmotion. Duplicate one of your favorite images four times. Use the … ellipses on top 
of each thumbnail to rename each image “Summer”, “Fall”, “Winter”, and “Summer”. When 
hovering over an image you will see a More button. Select this to see all the different options 
you have for editing your image. First, select the Location icon. Here you can change the Time 
of day. This is using a dynamic sky sun which is the best sun to take advantage of 
Twinmotion’s real-time features. 
 

 
 
To test out some of those real-time features, go to Media > Image > “Image name” > 
Weather. As you move the slider, you will see that the viewport immediately is affected by the 
changing precipitation and colors for Weather and Season. You can add additional effects by 
selecting the EFFECTS icon and editing the Wind speed or Smog. Curate your desired 
combination of these effects for each image you created. As you work with Revit Direct Link, 
you will be able to update the geometry for all images without losing the visual settings for each 
view. 
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Video lighting  
This part of the example will cover capturing the animated assets in Twinmotion as well as 
feature some techniques for lighting. First, go to the Media > Video and hit + to create a new 
video. This will automatically set the viewport view to be the first frame of the video. To explore 
the lighting options, select More on the right-bottom side of the video frame and then select 
LIGHTING. Select the pink text above Environment. This will show you the options for lighting 
the video. Dynamic Sun worked well for the weather feature in the series of images. To explore 
other options, select Sky Light HDRI. For this feature, Twinmotion uses a high dynamic range 
image to inform the lighting in the project. This example will not cover the third option, 
Backdrop HDRI which creates a new representation of the environment based on a 
hemispherical object in the scene. To further refine the settings to the chosen technique, Sky 
Light HDRI, select More and edit the settings as you’d like. 
 

 

 

Sky environments  
To replace the HDRI, select the thumbnail and hit Go to library. There, you will find many sky 
assets that are available to you with your Epic Games account. The workflow for using the 
assets is similar to the Quixel Megascans assets. Select your desired sky. Once downloaded, 
drag and drop the sky onto the thumbnail. 
 

 

 

Video production 
One option for using the Sky Light in a video is to create a new video frame with the Sky Light at 
a different rotation. To do that, go back to Media > Video > “Video Name” and select the + 
button. Now hit More for the new frame created and select Lighting > Sky Light HDRI. 
Change the rotation slider to a desired location. Go back to your video frames and hit the Play 
icon in the navigation toolbar to see how the keyed frames create nice cloud and lighting 
movement in the video. To add on to the video, select New video part in the toolbar. Add 
frames with various viewports to explore camera movement in Twinmotion. 
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Panorama 
To explore the other options beyond images and video, go back to the Media tab. You’ll find an 
option to create 360° panoramas. Select the + button to create a few panoramas throughout 
your project. These panoramas will be used later in the example as a feature option for 
Twinmotion Cloud. 
 

 

Panorama Sets 
To create a set of the panorama images created, go to Media > Panorama Sets. Hit the + 
button to start a new set and then select the Add Media to Panorama set to build out a 
featured set of 360° panoramas that will be used later in this example. 

 

Presentations 
Twinmotion provides a way to organize the media assets created. To utilize this, go back to 
Media and select PRESENTATION. Select the + button followed by the Add media to 
Presentation icon in the navigation toolbar. With these tools, you can curate a presentation 
experience by selecting specific images, videos, or panoramas. 
 

 

Cloud intro 
There are a few different ways of using the Presentation media tool. This example will cover the 
cloud capabilities that Twinmotion offers in Early Access for Presentations and Panorama Sets. 
Twinmotion Cloud is a powerful cloud-based service that you can use to instantly share and 
present high-fidelity Twinmotion Presentations and rendered Panorama Sets on the web. Since 
the experience is browser based, you can show your projects to stakeholders regardless of the 
performance capabilities of their computers, tablets, or smartphones, and without the need for 
them to download large files. 
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Upload to cloud 
To prepare your Presentations and Panorama Sets for the cloud, go to the Export icon in the 
dock. Select Empty above Presentation and Panorama Set to add the media you’ve created. 
Select Start export to upload the content to the cloud. A window will pop up prompting you to 
open up Twinmotion Cloud. 
 

 

Cloud library 
A browser window will open with all of the projects you have uploaded to the cloud. Select a 
project to see the sharing options on the right-hand side. Hit View to open up the cloud 
experience. 
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Revisit Revit workflows 
Twinmotion Cloud provides a quick way of sharing your work with stakeholders. As designs 
change inside Revit, your Twinmotion Cloud experiences may need to reflect those changes. 
This portion of the example will cover how to use the Datasmith workflows in Revit to 
synchronize the latest changes. 
 

Revit re-sync 
To update the geometry inside Twinmotion, open your Revit project and hit Synchronize. 
 

 
 
The green export status bar will once again appear in the bottom-right corner. Open Twinmotion 
to see a window with an import status progress bar. Once the update is complete, go to the 
Imports tab in the dock and select the … ellipses icon above the model you have imported. You 
will see additional settings for editing specific geometry and transformations. 
 

Next level 
This example has covered a wide range of information starting with Revit workflows, building out 
a scene using the Epic ecosystem, and then developing and sharing a narrative for your project. 
The next part will cover how you can take your Twinmotion project to the next level if additional 
interactivity is needed. In many use cases, Twinmotion’s toolsets are sufficient for a designer’s 
workflow and deliverables. In some circumstances, bespoke experiences are needed for the 
project. Design configurators, augmented reality experiences, digital twins, virtual production, 
and custom interactive applications are a few examples of bespoke experiences that it’s 
possible to create with Unreal Engine. The Datasmith workflows allow for Twinmotion projects to 
be imported into Unreal Engine so they can be developed further. 
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Bring designs into Unreal Engine 5 for bespoke experiences 
 

Twinmotion to Unreal Engine plugins 
If you are new to Unreal Engine, you can download the engine from your Epic Games launcher 
under the Library tab. For a greater understanding of the basics, check out the Unreal Engine 
documentation resource online.   
 

 
 
Once downloaded, open the Marketplace tab to download the Twinmotion plugins. Search 
“Twinmotion” in the search bar. You will be looking for the Datasmith Twinmotion Importer 
Plugin and Twinmotion Content for Unreal Engine Plugin. For more information regarding 
the limitations of the plugin, please read the information on the Marketplace plugin page. 
Download both plugins. 
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Datasmith Twinmotion Importer Plugin 
 
 
 

Twinmotion Content for Unreal Engine Plugin 
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Project setup 
To create a new Unreal Engine model, select Launch for the version downloaded. Navigate to 
the Architecture tab, and select Archvis. This is a great example project for getting started 
with architecture assets in Unreal Engine. Select the folder location, name your project, and 
select Create. 
 

 
 
Once the project is open, create a new level by going to File > New Level. Pick Interior or 
Exterior based on your project assets. Explore the scene and the text notes so you are familiar 
with some of the tools available to you in Unreal Engine. After getting familiar with the project, 
select the Geometry layers and the Notes layers in the outliner and delete the assets to have a 
blank canvas. 

  



 
 

 

 

Page 25 

Import Twinmotion project  

Next, you will need to add the downloaded plugins to the project. Go to Edit > Plugins and 
search for Twinmotion. Enable the Datasmith Twinmotion Importer and Twinmotion Content 
plugins. If a window pops up, read the information to get the latest information and hit Yes. 

 
The project will need to be restarted for the changes to take effect. Select Restart Now. 
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Now the project is ready to import the Twinmotion model. Quickly add to the project icon. 
Select Datasmith > File Import and navigate to find your Twinmotion project. 
 

 
 
A window will pop up asking you which folder you would like to place your project. You can keep 
the default Content folder and select OK. 
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A new window will pop up with import settings. Here you have the ability to choose which assets 
you would like to import. Your Twinmotion assets will load. If there are any incompatible assets, 
a new window will pop up giving you more information. 
 

 
 

Conclusion 
This example concludes in Unreal Engine. You are now ready to develop your Unreal Engine 
model further. For more technical resources and inspiration visit the Epic Developer Community, 
dev.epicgames.com/community, where you will find tutorial videos, forums, and more.  

 
Happy learning and exploring! 

  

 
 

 

http://dev.epicgames.com/community
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