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Next level design workflows in Fusion 360: 
Mixing T-Splines, meshes, and Voronoi-based 
patterns for product design 
Alex Lobos 
Rochester Institute of Technology 
 

 
Description 
This class explores workflows for taking bodies modeled in Fusion 360 and converting them to 
complex topologies via Voronoi-based patterns. These types of patters are organic and visually 
striking, resembling nature-based structures. This process is achieved by exporting bodies from 
Fusion into programs like Meshmixer, ReCap Pro and Voronator, where it’s easy to apply 
different types of patterns. The resulting meshes can be brought back into Fusion and turn them 
back into T-Splines for further development. A key benefit of this workflow is that designs 
combine different types of geometries (i.e. solid faces with Voronoi-based patterns) in a single 
body. An example of this workflow can be found 
at: https://gallery.autodesk.com/fusion360/projects/119363/stool-16 
 
 
Speaker bio 
Alex Lobos is an industrial designer and educator, focusing in sustainable design, emotional 
attachment, user-centered design, and CAD applications. He is Graduate Director and 
Associate Professor of industrial design at Rochester Institute of Technology, New York. He is 
also an Expert Elite for Fusion 360 software, Autodesk University Featured Speaker, member of 
Autodesk University’s Advisory Council, and a recipient of Fusion 360’s Education Award. He 
has collaborated with Autodesk since 2011 on research projects and teaching methods for 
design, engineering, and sustainability. 
 
 
 

Learning Objectives 
• Learn how to transform basic designs created in Fusion 360 into complex shapes 

that use generative design topologies such as Voronoi patterns. 
• Discover options for importing and exporting different body types, including T-

Splines, B-Reps, Meshes, Tri-faces, and Quad-faces. 
• Learn how to use programs such as Fusion 360, Meshmixer, ReCap Pro, and 

Voronator to export, transform, and edit bodies. 
• Explore how meshes can be imported back into Fusion 360 and be combined with 

T-Splines bodies. 
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Benefits of combining topologies 
 
CAD (Computer-aided design) is a wide category of tools for creating three-dimensional bodies 
and assemblies with the use of computers. There are several types of CAD models, developed 
by different companies for various applications. Some of the most common types include 
“parametric,” which is based on boundary representations, and “NURBS,” which stands for non-
uniform rational b-splines, and allows for direct modeling techniques.  
 
Although applications vary by users and industries, parametric modeling is more common in 
mechanical/industrial applications, while NURBS is used for transportation and media & 
entertainment. Product and industrial design tend to sit in the middle of these two approaches, 
given that designers often combine the creativity of complex form generation with specific 
manufacturing and fabrication requirements. 
 
It is important to understand how CAD model types work, including their benefits, limitations and 
differences. Just as important is the combination of different types into single, dynamic 
workflows. Each geometry type provides unique attributes that when combined, can provide 
designers and engineers with better results than if using a single type of model. For example, an 
important benefit of importing multiple files into a program, including meshes, is the ability of 
capturing physical objects with 3D scanning and bring them into CAD workspaces either as 
reference for modeling new bodies, or more recently, to be able to edit them as much as a body 
that was created in the computer. Combining different CAD types can be an effective way for 
achieving a wider type of workflows and geometries, rather than just being a list of geometry 
alternatives to choose from. 
 
Along with understanding how CAD types work and how they can be combined, it is important to 
understand how they can be imported and exported between different programs. When Fusion 
360 was released, for example, it was very hard to bring into the program file formats that were 
not native to it. Formats such as STL or OBJ could be imported into Fusion as static, “dumb” 
files, meaning that they could only be placed in the workspace but could not be edited beyond 
cutting them. Other programs such as Meshmixer, Mudbox and Recap Photo (previously 
ReMake and Memento) provide far better flexibility for editing and combining different file types. 
Recently, Fusion 360 has improved significantly its ability to import different file types as well as 
including ways for editing meshes within Fusion and combine them with native bodies. All these 
options provide more versatility for integrating multiple CAD data into single workflows that can 
be edited and shared without design intent.  
 
 
Geometry types 
 
Below is a brief list of different geometries that are common in CAD models, including their 
typical appearances in CAD workspaces (Figure 1). Most types will be able to define similar 
components of a body, such as faces, edges, vertices and control points. The difference in most 
cases is in how these components are created and how they are defined in space. Some cases 
such as B-Reps are able to fully define every component in a geometry, while other ones 
generate shapes that cannot be fully defined or edited. A better understanding of their qualities 
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and limitations is a key component for combining different types of geometries into single 
workflows.  
 
B-Rep 
B-Rep stands for Boundary representation typical of parametric models. It’s a body comprised 
of multiple surfaces. As the surfaces touch each other, they define faces, edges, vertices, etc. 
B-rep’s define geometries with great precision and surfaces are defined by equations. B-Rep’s 
are completely editable. 
 
T-Splines 
It’s a NURBS-based surface with control points that can start/finish at any point, without having 
to traverse the entire surface. T-Splines are completely editable. As opposed to B-Reps, T-
Splines are not parametric because not all components in their topology can be fully defined 
with equations. 
 
Mesh 
It’s a polyhedral 3D body tessellation comprised of vertices, edges and faces. Faces can be 
triangular or quadrilateral, which refers to the terms mesh-tri and mesh-quad. Meshes are as 
precise as B-reps as the geometry is defined by tessellations of faces instead of full equations. 
Meshes are not editable. They can be cut but their geometries cannot be changed. 
 

          
 

Figure 1: From left to right: B-Rep, T-Spline and STL bodies. 
 
 
Interest in Generative topologies 
 
The core benefit of generative design lies in automation and can be understood from two 
angles: processes and form generation. On one hand is the automation of repetitive processes, 
which is perhaps the most important benefit of generative design. Architecture, Engineering and 
Construction industry is an ideal scenario for applying automated processes where the planning 
construction of large buildings that require multiple systems working together. Automation is of 
great benefit in large scale projects such as buildings, bridges and urban infrastructure require 
repetitive implementation of similar components such as doors, windows, plumbing, electrical 
outlets, framing structures, lighting, etc.  
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Another benefit of generative design is the creation of forms that mimic nature. By using 
algorithms that generate forms out of follow basic, progressive rules it is possible to develop 
structures that are complex, intricate, and that have a naturally fluid and efficient. Designers 
look for ways of creating nature-inspired forms due to their unique appearance, intricate detail, 
and strong reaction from consumers.  
 
 
Voronoi patterns 
 
Voronoi patterns are subdivisions to a plane or surface that are all at the same distance from a 
specific point, named seed. Each resulting subdivision is called a Voronoi cell. They are found 
and applied in a wide variety of scenarios, and in the case of CAD, they are a fairly easy way of 
creating nature-inspired patterns that fit within a designated area. A reason why they have 
become popular for creation of designed structures is that they resemble biological structures 
(Figure 2). When used as tridimensional patterns, they tend to create structures that are stable 
and strong with minimal use of material, as opposed to structures that are solid or hollowed out 
with simple geometric sections. 
 

 
Figure 2: Sphere with three-dimensional Voronoi pattern 

 
 
Design examples  
 
The is a wide array of applications for this type of workflows. Below are two examples of 
geometries that were originally modeled in Fusion 360 and then converted into complex meshes 
with Voronoi-based patterns. Both the solid and Voronoi versions were re-meshed in other 
programs and brought back into Fusion 360. This workflow allows for taking advantage of 
complex geometry generation with the modeling flexibility of Fusion.  
 
In both of these cases, the final design is envisioned to be fabricated with additive 
manufacturing, as complex meshes such as these are not suitable for traditional manufacturing 
process such as molding or carving. 
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Seating stool 
The first example is a stool, which was originally designed as a solid, single piece (Figures 3 
and 4). The body was then turned into a Voronoi-based body, and eventually brought back into 
Fusion (Figure 5). The top section remains solid and the bottom sections incorporate the 
Voronoi geometry. The result is a piece that is stronger and more visually engaging.   
 

 
Figure 3: Stool modeled in Fusion 360. 

Voronoi-pattern created in voronator.com 
 

 
Figure 4: Stool modeled in Fusion 360. 

Voronoi-pattern created in voronator.com 
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Figure 5: Screenshots of Fusion 360, showing how the geometry 

was developed separately and then connected. 
 

 
 
Bass guitar 
A second example is a bass guitar, which was also modeled as a solid piece. Voronoi patters 
were applied to the main body and to the neck of the instrument (Figures 6 and 7). This creates 
a dramatic visual detail that also makes the bass guitar lighter. The body remains solid in the 
center, in order to fit electronic components and to maintain the acoustic qualities necessary for 
the instrument to produce a good sound.  
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Figure 6: Bass guitar modeled in Fusion 360. 

Voronoi-pattern created in voronator.com 
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Figure 7: Bass guitar modeled in Fusion 360. 

Voronoi-pattern created in voronator.com 
 
 
Modeling workflows 
 
Below are a series of workflows that illustrate common workflows for importing, 
exporting, editing and mixing different geometries. The tutorials cover several programs 
and applications, since it is hard to find a single one that can handle all of these different 
workflows. The tutorials illustrate the following common workflows: 
 

1- Save body as STL. This tutorial shows how a body in Fusion 360 is saved as STL, a 
fairly universal format for mesh geometries. 

2- Create patterns and geometries. There are several ways of turning solid bodies into 
more complex ones. These tutorials show two examples: 2.a illustrates use of Voronoi 
patterns and 2.b illustrates variable meshes. 

3- Convert meshes from Tri to Quad. In order to convert a mesh in Fusion 360 into a T-
Spline body that can be edited, meshes need to have quad faces. This tutorial shows 
how to achieve this format (OBJ-quad) outside of Fusion 360. 

4- Meshes imported into Fusion in both Model (B-Rep) and Sculpt (T-Spline) 
environments. B-Rep conversions work well when the mesh is used in more 
mechanical/parametric applications. T-Spline conversions work well when additional 
modeling/sculpting is needed. 



 
 

 Page 9 

5- Mixing meshes and T-Splines. This tutorial shows how to combine imported meshes 
that were converted to T-Splines, in applications similar to the bass guitar and stool that 
were illustrated above in this paper.  

 
1- SAVE BODY AS STL (In Fusion 360) 
Go to Create > Sphere. 
Pick any plane to create a 
sphere of 100mm 
diameter. 
 
If modeling in “Sculpt” (T-
Splines), make sure that 
you press “Finish Form” to 
bring it into “Model” (B-
Rep) environment. 

 
 

In the left panel, go to: 
Browser > Bodies and click 
the side arrow to expand 
the bodies in the model.  
Find the body 
corresponding to the 
sphere, “right-click” and 
select “Save as STL” 
 
Adjust settings (default 
settings work well for most 
situations) and save STL 
file. 

 
 

 
 
 
 
 
 
 
 



 
 

 Page 10 

 
2.a - CREATE VORONOI-BASED BODY (In Voronator.com) 
In a web browser, go to: 
Voronator.com 
 
In the website, upload the 
STL file. 
 
Click on “Show advanced 
features”. 
 
Select “Output Format” as 
STL. Also select desired 
“number of holes” and 
“thickness of new layer” 
 
  

 
When the file is ready, 
download it to your 
computer. 

 
 

 
 
 
2.b - CREATE A VARIABLE-MESH BODY (In Meshmixer) 
Import STL file 

 
 



 
 

 Page 11 

In order to randomize the 
density of the faces, go to: 
Left panel > Sculpt > 
Brushes > Reduce. 
 
Click the sphere’s faces to 
alter them. 

 
 

In order to turn the body 
from solid to open mesh, 
go to: Left panel > Edit > 
Make Pattern 
 
Change “Pattern Type” to 
Dual Edges and adjust 
settings as necessary.  
 
When done, click “Accept”. 
 
 

 
 

In left panel, go to: 
Analysis > Inspect to “Auto 
Repair” and select all faces 
(typing “Command+A” or 
with a selection 
window/lasso). 
 
Go to Edit >Remesh to 
improve the quality of the 
face distribution.  
 
Go to Edit>Reduce to bring 
down the number of faces 
in the body. 
 

 

Go to: File > Export and 
export file as STL. 
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3- CONVERT MESH FROM TRI TO QUAD (In ReCap Photo) 
Open Recap Photo. 
Select “Load a Model” and 
choose the STL file 
exported from Fusion. 

 
 
 

Select the entire body. 
 
In the left panel, go to: Re-
Topologize > Decimate, 
and reduce the number of 
faces to under 100k. 
 
Go to: Re-Topologize > 
Retriangulate Selection, to 
recreate the faces and 
make them more even. 
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In the left panel, go to: 
Analyze > Diagnostics. 
 
Click on “Detect Issues” 
and select to fix any issues 
that Recap identifies. This 
process might need to be 
repeated several times 
until no issues are 
detected. 

 
 
 

In the left panel, go to: 
Export > Export model. 
 
Export as “OBJ(Quads)”. 
This is the only format that 
will allow to convert the 
body to a T-Spline when 
imported in Fusion 360. 

 
 

 
 
4.a - CONVERT MESH (QUAD or TRI) TO B-REP 
In Model environment, go to 
the top panel and select: 
Insert > Insert Mesh. 
 
Select the STL file of the 
solid sphere. 
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In the lower-right corner of 
the workspace, click on the 
“Options” icon (grey gear 
icon) and select “Do not 
capture Design History” 
 
IMPORTANT: Mesh tools 
are available in Fusion 
ONLY when History is 
disabled.   

 
 

In the left panel, expand 
“Bodies” and look for the 
sphere’s icon. 
 
Right-click on the icon and 
select “Mesh to B-Rep”. 
 
 

 
 

IMPORTANT NOTES: 
• Fusion only converts meshes to B-Reps that have less than 10,000 faces.  
• This limitation doesn’t apply to meshes converted to T-Spline in the Sculpt 

environment. However, bodies with large number of faces become unstable and affect 
Fusion 360’s performance. 
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4.b - CONVERT MESH (QUAD) TO T-SPLINE  
In the top panel, click on 
the purple box to enter 
“Sculpt” environment (T-
Splines) 

 
 

In the top panel, go to: 
Insert > Insert Mesh  
 
Select the OBJ-quad file 
that was created in Recap 
Photo.  
Right-click on the mesh 
body and select “Convert” 
to create a T-Spline 
version. 

 
 

The body is now a T-Spline 
which can be further edited 
and/or combined with other 
T-Spline bodies.  
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In the top panel, click on 
“Finish Form” to convert 
the file from T-Spline to B-
Rep and return back to 
Model environment. 

 
 

The body is now a B-Rep 
body, which can be further 
edited and/or combined 
with other B-Rep bodies.   
 
 

 
 

 
 
5 - CONVERT MESH (QUAD) AND MIX WITH T-SPLINE 
 
Note: When combining bodies, it is important to have geometries as simple as 
possible. When using the method described here, it helps immensely to create 
versions of the body that are just planes and don’t have thickness. 
 
For the Voronoi version: 

• Go to Voronator.com and create an STL with plane only (no thickness). 
• Open the output STL in Recap Photo and go through similar steps as for the Voronoi 

version: 
o Reduce faces (aim for under 25,000 faces). 
o Remesh the geometry. 
o Export as OBJ-quad (set target for about 5,000 faces). 
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For the solid version: 

• Use the solid STL created in Fusion 360. 
• Open in Recap Photo and go through the similar steps as for the Voronoi version: 

o Reduce faces (aim for under 25,000 faces). 
o Remesh the geometry. 

• Export as OBJ-quad (set target for about 10,000 faces).  

 
Once these two new OBJ files are ready, proceed with the steps below. 
 
In the top panel, click on 
the purple box to enter 
“Sculpt” environment (T-
Splines) 

 
 

In the top panel, go to: 
Insert > Insert Mesh  
 
Select the OBJ-quad file of 
the voronoi-based sphere 
with planes only (no 
thickness) that was created 
in Recap Photo. 

 

Right-click on the mesh 
body and select “Convert” 
to create a T-Spline 
version. 
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In the left panel, go to 
Bodies. 
 
Right-click on the T-Spline 
body and change display 
mode to “box display”.   
 
This will help to see the 
faces more clearly and to 
maintain the 
performance/speed of the 
computer. 

 
 

Select faces along the 
equator of the sphere 
(widest horizontal section) 
and delete them, in order 
to break the body into an 
“upper” and “lower” 
section.  
 
Note: Make sure that you 
are looking at the model 
from the front/sides and not 
from an angle. Otherwise 
you won’t delete the faces 
at the right location 

 
Selected edges 
 

 
As edges are deleted body is split in two. 
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After going all around the 
sphere, delete the bottom 
portion. 
 
In the right panel, go to the 
top portion body, right-click 
and make it “un-
selectable”.  

 
 

Repeat these steps for the 
solid version of the sphere, 
which will be used for the 
bottom part. 
 
Make sure that the is a little 
bit of open space between 
the top (Voronoi) and 
bottom (solid) portions.  

 
 

In order to connect the 
open edges of the top 
section with the bottom, go 
to: Modify > Bridge. 
 
Continue doing this all 
around both bodies. 
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When finished connecting 
all edges with Bridge, the 
bodies should become a 
single unit again. 

 
 

Go to: Modify > Thicken to 
add thickness to the body. 
Set thickness to 1mm, 
expanding outwards and 
thickness type to “Soft”. 

 
 

Body is finished. Press 
“finish form” to convert the 
file from T-Spline to B-Rep 
and return to Model 
environment. 
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