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Description 

Vault Professional software is a powerful tool for data management, relying heavily on meta 
(property) data. Do you know how to access them? Where you can access them? How to create 
mappings to your CAD files? And how to use this information not only in Vault Professional, but 
on your CAD files themselves? See examples from the speaker’s own Vault Professional setup 
to learn about the power of property data, how to use it, and how to share it. 

 

Speaker 

Mike is the Technical Services Manager at Prairie Machine a mining equipment manufacturer. 
Reporting to the general manager, Mike is responsible for overseeing the company's technical 
operations and strategic technical growth. His primary duties include the ongoing support of 
critical computer applications and the interactions between departments. 

 

 

 

Learning Objectives 

• Learn how to find properties in Vault Professional 

• Discover the difference between system- and user-defined properties 

• Learn how to map properties to and from your CAD files 

• Learn how to share property information with other systems 
 

http://www.prairiemachine.com/
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Vault Properties  

Meta Data 

What is metadata? “a set of data that describes and gives information about other data” 
[Oxford Dictionary] 

Meta means beyond making metadata the data about data It describes and provides a summary 
about the data making it easier to track and work with the data 

What are Vault Properties? The attributes associated with your data, your files, items, change 

orders, folders, and custom objects. 

Vault provides two types 

• System Properties are out of the out of box properties; the ones defined by Vault 

• User Defined Properties (UDP) are those defined by the Vault Administrator 
 

Property Management is not the same across all flavours of Vault. For example, Outlook email 
integration and the Vault Item Master are only available with Vault Professional. 

 

Data Extraction 

Autodesk Vault allows you to store documents of ANY type, however there are differences with 
how capable Vault is for viewing and dealing with metadata from the various file types. 

 

 

 

In addition to AutoCAD, Inventor, Revit, and MS Office the Vault add-in is available for Factory, 
the Alias Suite, 3DS Max, Advanced Steel, Navisworks, and SOLIDWORKS.  

Notes: 

• Inventor LT & AutoCAD LT are only available with Vault Workgroup/Professional 

• FDU, Revit, and Outlook with Vault Professional 
 
The act of checking-in a file populates Vault with the available property information.  
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User Tasks 

Users interaction with Vault properties centers around adding the data to Vault. This is the building 
blocks. Data including adding files, creating change orders, building items, and interacting with 
custom objects. 

Vault indicates property compliance via a specific column. The icons represent if the property is 
compliant, non-compliant, pending, or has failed the evaluation. 

With the data added users can edit property values, add (or remove) properties, and synchronize 
the properties (between items and files and between Vault and the local file store) 

Editing Properties 

Use Edit Properties (a modal dialog) or the Property Grid (a dockable palette). Editing 
properties is available on all object types, but you need to be an editor or admin. You can edit 
multiple objects, but not all properties are editable. 

From the main grid, select the object(s) and from the Edit menu select Edit Properties (or press 
Ctrl E) 

 

o use the Add and Remove options to add and remove objects from the dialog 
o with Select Properties you select the property definitions to be displayed in the editing 

grid.  Read-only properties display with a grey background. 
o Use Find/Replace to quickly locate values & for mass replacing values with a new value 
o Double-click a value to edit it 
o Right click to copy and/or paste a value.   
o Select a single cell and click-and-drag the small black square to place that value into 

multiple cells at one time.  
o The new value must match the property’s data type or the entry will be marked as 

incorrect. 

When finished editing select OK to process the changes.  When finished updating the Property 
Edit Results displays the results for each property edited. 
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Enable the Properties Grid from the View menu. This grid can be moved to other locations, 
depending on your needs. 

 

To edit properties, select a file or group of objects. Using the Pencil Icon menu select Edit 
Properties to open edit dialog with the last used settings. To edit specific properties, select a group 
of files in the main view, then select a group of properties in the grid, and select Edit Selected 
Properties. 

 

When editing properties Vault increments the version, creating a new version with the 
changes. If using lifecycles the object must be in the work in-progress (WIP) state to modify 
properties. 

 

Add or Remove Properties 

In the above section we talked about how to add or remove properties from the proerties grid, but 
what if the object does not contain the specific propert? Select an object and from the Actions menu 
select Add or Remove Property.  A list of available property definitions appear, which you can 
select the aproperties to add to the object. 

Synchronize Properties 

Often you may see a situation where a local file property value does not match the value of the 
same property in the Vault.  

  

To fix this, select the files and use Synchronize properties (Actions menu).  Depending on how 
your properties are mapped, the file property and Vault property will be brought to the same 
value, and the error icons cleared.   
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Add Ins 

Updating Properties 

Editing properties within Vault can leave your local copies out of date. However, during check-out 
Vault will prompt you to update the local copy.  

Or, you can use Update Properties (Vault Add-in). This software-side tool synchronizes the 
property values between the local file and the Vault data.   

 

Inventor Data Cards 

Use Data Cards to view and edit multiple properties from within Inventor, updating both the local 
file and the Vault data. When first opened, the view defaults to a thumbnail image and the values 
of Vault Status, Category, Lifecycle State and Revision. 

 

Expand the data card by clicking the >> in the lower right corner.  Once expanded, the card will 
show the properties that were set up inside of Vault by the administrator 

 

The Edit button opens the properties for editing. If more than one page was set up in the Vault, 
you will see multiple page tabs.   

To create a card deck, select the Get Entire Model.  All files associated with the top level are 
added to the card deck.  To scroll through the files on at a time there are forward and back 
buttons along the top, as well as a Home button to take you back to the top level. 
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Inventor Data Mapping 

Within Inventor, use the Data Mapping feature to map report data onto the components contained 
within the model. The displayed chart corresponds with the coloring of the model. In the image 
shown below, the grey color represents the components currently checked out by mthomas and 
the green represents components currently not checked out. 

 

 

Data Mapping is advantageous in that it provides a visual representation of your Vault property 
information, and how it impacts your models. 

Use the dropdown along the top of the Map Report Data panel to select the desired report. With 
the report picked select the Generate Report icon (to the right of the dropdown) to generate the 
report and populate the chart. Use the toolbar to map the data on the model, choosing the 
desired level before applying the coloring.  

The Autodesk Knowledge Network (AKN) contains information on creating your own reports.  
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Property Administration 

Properties are available for files, folders, items (Vault Pro), and custom objects (Vault Pro). You 
associate with the entity classes the available properties. Mapping determines where the property 
gets its information from. 

 

 

Figure 1: Common Terms 
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When files are checked into the vault, only the properties that are set enabled are automatically 
extracted and indexed by default. 

Creating and editing properties – Tools > Administration > Vault Settings > Behaviors > 
Properties. 

In the Property Definitions dialog select New 

• Specify the Name 

• Select the Property Type 

• Assign the UDP to one or more Categories  

• Use the Settings to optional further configure the property (see below) 

• Optional configure Mapping 

 

Map properties so that values from the master file (like a file property) write to the property 
on file check-in or on item assignment. 

For examplemapping AutoCAD titeblock, AutoCAD drawing properties, AutoCAD 
Electrical Project information, and Inventor iProperties to the Item Description property 

  

Vault provides 4-data types: Boolean (True or False), Date, Number (Integers only), and Text 
(strings). 
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The association is the attribute determining to what 
the property is available. This varies on the version of 
Vault you are using, for example Item is only available 
with Vault Professional. 

When creating a new property, ask yourself… 

 

What data type is required (text, boolean, or number)? 
Should it be included in searches? 
Is there a list of values?  
Should the user only pick from the list? 
Is there a initial (default) value? 
Is it mandatory (required)? 
Sensitive to case? 
A minimum and/or maximum length? 

 

Disabling a property will prevent it from being indexed by Vault.  This may be used to “shut 
off” properties that are in use on files, but are no longer needed.  If a property is in use 
anywhere in the Vault, it cannot be deleted. 
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Index AutoCAD Block Attributes 

From the ADMS Console add AutoCAD blocks (by name) to index the attribute property values 
allowing you to map block attribute properties to Vault properties.  

Within the ADMS,  select Tools > Index Block Attributes… 

 

Within the Index Block Attributes dialog select New. Enter the name of the attributed block for 
attribute extraction. The name is case sensitive. 

Optionally enable the option to extract the attribute prompt instead of the tag.  

If drawings exist within your Vault that contain the attributed block a re-index will be required. 
The re-index extracts the information, making it searchable and available to your properties.  
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Lifecycles 

Our drawings and models are the language of engineering and manufacturing. It is how we 
communicate with others. It is how we go from concept-to-design-to-manufacture. How we 
manage this language is as important as the documents themselves. 

It is important to maintain a history of a document (including drawings) to track what has 
changed, when it changed, and hopefully why it changed. This history aids in making better 
decisions, provides crucial customer information, and provides the means to go back to a 
previous version. 

If you are using Autodesk Vault Basic you will not have access to the lifecycle engine. Vault 
Basic only provides version control, no tools to manage the change. Vault Workgroup and 
Vault Professional provide the tools for managing change 

From Vault’s help: “A lifecycle definition is an engine that can be configured to automatically 
assign security, behaviors, and properties to Vault objects based on where the object is in the 
life of the design process.” 

The lifecycle engine is available for files and folders, and additionally within Vault Professional 
custom objects and items. 

Building your Properties is one of the key steps to establishing lifecycles. 

Categories are labels, providing a method to group objects logically. Categories assign user-
defined properties to the objects, the available lifecycle definitions, and the available revision 
schemes. 
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Use Rules to define conditions where objects automatically assign to a category based on the 
object’s properties.  

Item properties take precedence over the associated files.  If the value of a property on a file is 
modified and the properties are synchronized, the value of that property on the Item will over 
write the File property value.   

 

The State identifies the object’s status within the lifecycle. The state identifies the object’s status 
within the lifecycle. The state determines the Property Criteria requirements (Compliance) 
that must be in place before the state change can occur, the actions that happen during the 
change (i.e. revision bump), and the security enforcing who can make the change and who can 
see the file in the state. 
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Projects 

Vault Projects are folders you manage with lifecycles. With projects you organize the related 
data and manage it from one location.  

 

Figure 2: Projects 

Convert the folder to a project by assigning a 
category.  

Projects have properties, meaning a terrific location for project data.  

Projects are like files except you cannot set the revision. After applying the desired category, 
adjust the state of that folder. The state change configuration may force you to perform the state 
change on the files contained within the folder as well. 

 

Figure 3: Project Reports 

Run reports on the project to gain 
insight including information on the 
files, items, sub-projects, and other 
objects contained within the project.  

Access reports from the Preview tab 
of the project. 

 


