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This class will present tips and tricks on how to get the most out of Civil 3D by exchanging files 
between Map 3D, InfraWorks and 3DS Max Design. You will learn how to convert legacy 2D as built 
pipes networks into 3D, visualize the integration of existing pipes network with proposed pipes in 
InfraWorks, create 3D roundabout using Vehicle Tracking and use Autodesk Civil View to export Civil 
3D roundabout data into Autodesk 3ds Max Design. 

 

Learning Objectives 
At the end of this class, you will be able to: 

 Convert multiple polylines to Civil 3D pipes using Map 3D 

 Integrate Civil 3D models into InfraWorks 

 Integrate roundabout design using Vehicle Tracking 

 Use Civil View for 3DS Max Design and create simple animation 
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Objective 
In this class you will learn tips and tricks on how to get the best out of the Infrastructure Suite  

by bringing data from Civil3D to Map 3D, Vehicle Tracking, 3DS Max Design and InfraWorks 

360. My intention is to share with you Civil 3D interoperability between these products. The 

data that will be used for this class will be divided into 2 parts, in the first part, I will focus on 

working with Civil 3D, Map 3D and InfraWorks and part 2 will focus on creating roundabouts 

using Vehicle Tracking in Civil 3D and 3DS Max design. 

Part 1: Working with Civil 3D, Map 3D and InfraWorks 360 

Assuming you have legacy 2D utilities drawing in particular pipe networks and you would like 

to convert them to 3D pipe networks using Civil3D.  

  



Civil3D Interoperability: Making the Infrastructure Suite work for you 

3 
 

Object Data 

We will start with Mapping pipes properties 

using Object Data in Map 3D. First, go to Map 

Setup Ribbon and pick on Define Object Data 

and then click on New Table..give it a name 

This Table will represent a typical parameters 

of a pipe, so we will give our Table the name 

“Pipe”.  

 

 

 

 

 

 

 

 

Tips: When adding new Field, try to give a name that’s similar to the Pipe Properties in Civil 

3D. This is helpful during Mapping of the Fields where you can specify the pipe feature 

classes to be imported, and assign the corresponding AutoCAD Civil 3D properties. 

 

Once you’ve created the Object Data for Pipes, repeat this for Structures. 

Next, you can start attaching the Object Data to the Pipes and Structures. 

Define Object Data 
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Let’s start by attaching Pipes Object Data to Pipes and followed by Structures.  

Hint: you can isolate the Layer which shows only the pipes and attach the Pipes Object Data 

to all the pipes.  

We can then start assigning or modifying the properties of the pipes and structures. 

 

 

The completed drawing with Object 
Data attached can be found in the 
CV5226-Data folder under DWGs, 
titled Map3D Pipe.dwg. 
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Export data to SHP  

Now we have all the Object Data attached to the pipes and structures, we can export them 

as a SHP file to be used in Civil 3D.In the Planning And Analysis Workspace, click Output 

tab Map Data 

Transfer panel  

 

 

 

In the Export Location dialog box, select the ESRI Shapefile format and a location for the 

exported files. Click OK. 

In the Export dialog box, specify Line as the object to export. 

 

 

On the Data tab, click Select Attributes and select the Pipes Object data to export with the 

objects.  
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Repeat the same steps for Structures but instead of Line, choose Point for Object type in the 

Selection tab. 

You should get the following message if the export has been successful. 

 

 

 

Import GIS data using Civil 3D 

Now we are ready to import the SHP files and convert them to multiple pipes in Civil 3D 

automatically.  

Before we begin, do make sure that you’ve selected the correct template and Pipe Network 

Catalog. For example, if you prefer to use the _AutoCAD Civil 3D (Metric) NCS.dwt 

template, make sure you set the Pipe Network Catalog to Metric. 

You can also find the exported shp 
files for both pipes and structures 
under the CV5226-Data>SHP 
folder. 
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In this class, I will use the _AutoCAD Civil3D 2015 ANZ Design_ANZ.dwt template. I will 

therefore set the Pipe Network Catalog to ANZ Metric.  

 

Once these settings have been set, go to Insert Ribbon tab, Import panel and select Import 

GIS Data. 

 

We will select a single SHP file, browse to the location 

where the Pipes.SHP have been saved. Then click 

Connect. 

 

For SHP Path, you can  

1. : Select a single SHP file. 

2. : Browse to a directory that 
contains multiple SHP files. 
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In the Object Options Page (Import GIS Data Wizard), give the Network a name, select 

_ANZ Part List (if you have chosen the Metric template, make sure to pick Standard from the 

list). 

 

 

For Schema and Coordinates, please select MAL-MRSO as the system code. 
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Next, we can start Mapping imported pipe feature from the SHP file with Civil 3D pipe 

properties. 

 

 

On the Data Mapping: Structures page, it will be greyed out as we haven’t connect to the 

Structures SHP file. Click next to the Query Options Page. This page gives you the option to 

filter the imported GIS data to a specified area in the current drawing. We will imports all GIS 

data with no filter. 

Load Data Mapping: 

Loads a saved data 

mapping file, which 

overwrites the contents 

of the Pipe Attribute 

Assignment table. (This 

has been saved as 

PipeDataMapping.xml, 

you can use this file to 

apply the mapping 

automatically) 

Save Data Mapping: 

Saves the current data 

field and data unit 

combinations for later 

use. 
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On the Clean Up Page, it allows you to specify the cleanup options for disconnected pipes 

and structures. 

 

 

Click Finish to complete the Import process. 

  

Then, repeat the whole process for Structures 

.  

Final touchup for Imported Pipes and Structures 

You will noticed that there will be 2 Pipe Networks.  

Snap Pipe and Structure Tolerance 
Specifies the tolerance value for snapping the end of a disconnected pipe to the nearest 
structure. If the end point of a disconnected pipe is less than or equal to the tolerance 
distance from a structure, the pipe will be connected to the structure automatically. 
Discard Unlinked Pipes 
Specifies that disconnected pipes are not imported. 
Discard Unlinked Structures 
Specifies that disconnected structures are not imported. 
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Now that you have both the pipe networks merged, there is only 1 final task which is to 

connect the structures to the pipes and there you have it, you have completed the task of 

converting multiple lines and points to pipe network. 

 

Exporting pipe network to InfraWorks 

Pipes and structures are exported to the IMX file as pipes and pipe connectors. Once you 

have completed converted the multiple line to Pipe network, save the drawing. Go to Output 

ribbon tab, Export panel and click on Export IMX. 

MERGEPIPENETWORKS 
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We will also export the Parcel lines to InfraWorks as SHP. To do that, in Civil 3D, enter 

MAPEXPORT in the command line. In the Export Location display box, give it a name and 

Under the Files of Type, select ESRI Shape file (*.shp). 

 

Pick Line under Object type and click OK. We are now ready to bring in data from Civil3D to 

InfraWorks. 

 

 

Bringing data to InfraWorks 

In InfraWorks 360, click on the InfraWorks Home icon (big orange circle with the letter I). 

Once you click the InfraWorks Home icon, there will be a toolbar which expand to the right 

and you will have other icons appearing. Click on Create and manage your model. It will 

bring up a vertical toolbar, click on Data Sources. A Data Sources window panel will appear 

on the right where you can manage different sources of data. 

Import GIS Data completed both for Pipes and Structures. The completed drawing 

can be found in CV5226-Data\DWGs\ImportGISData Pipe-Complete.dwg 
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Let’s open an existing InfraWorks (AU-Pipes.sqlite) model which already has roads and 

terrain imported. Then we will bring in the pipes and parcels which we exported as IMX into 

InfraWorks. In the Data Source panel, expand the Add File Data Source menu, click on 

Autodesk IMX and browse to \CV5226-Data\IW360ImportGISData Pipe-Complete.imx.  

 

Both Pipes and Structs data will automatically be checked, click OK. You will notice that both 

the Pipes and Structures are not visible yet because you will need to configure the data 

source by providing the coordinate system so that the data ends up in the correct location 

spatially. You can double-click on the Pipes data source to configure. 
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Repeat the same for Pipeline Connectors or structures. Since the pipes and structures 

underground, you may not see it in the model, make sure to toggle the Surface Opacity. 

Surface Opacity makes the surface more transparent or opaque. Making the surface 

transparent allows you to view features below the terrain. 

Enter MAL-MRSO in the Coordinate System or you can select 

from the drop-down list> Malaysia>Peninsular Malaysia, RSO 

System, Metres. 
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 Click      to display the Visual Effects panel. 

 Use the slider to adjust Surface Opacity. 

Move the slider all the way to the left to make the surface completely transparent; move it all 

the way to the right to make the surface completely opaque. 

Alternatively, you can click on the InfraWorks home icon, click on the Create conceptual 

design features which will bring up a set of vertical toolbar, pick Surface Opacity. This option 

allows you to toggle surface opacity between 50% and 100%.  

 

 

Next, we will bring in the parcel 2D lines which we have exported earlier. In the Data Source 

panel, expand the Add File Data Source menu, click on Autodesk IMX and browse to 

\CV5226-Data\SHP\Lots.shx. Right-click on Lots and click on Configure… 
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In the Data Source Configuration window, select Coverage Areas under Type. Under Geo 

Location tab, enter MAL-MRSO in the Coordinate System. Then, go to Table tab, under 

Stylization>Manual Style, Click  to open the Style Chooser and select 'Coverage/Grass 

With Gravel Border'. Set 0.2 m for Geometry>Generalization and Cover>Buffer 
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Part 2: Working with Civil 3D, Vehicle Tracking and 3DS Max Design using Civil View 

Vehicle Tracking Drawing Settings 

Modelling 3D Roundabout in Civil 3D has definitely come a long way. In the past, we used 

the Intersection wizard and made some tweaks here and there in order to get a decent 

roundabout. Those were still great tools but with Vehicle Tracking, you practically can create 

3D roundabout on the FLY… 

Before we get started, let’s take a look at the Drawing Settings. 

 

Review the Units and scale settings, in this class I will pick all SI base units. Next, under 

Surfaces, pick EG as Existing Surface and leave Final Surface as [Undefined]. 
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We will accept the default settings for Styles and Paths.  

Under Junctions, the options given in the page control how much of the 3D model Vehicle 

Tracking creates and updates. 

1. Tick Create Alignments to create horizontal alignments in your CAD system. 

2. Tick Update Alignments if you want Autodesk® Vehicle Tracking to update the alignments 

automatically when the geometry changes.  This option is only available if Autodesk® Vehicle Tracking 

created the Tickoriginal alignments, i.e. if Create Alignments is ticked. 

3. Tick Create Profiles to create vertical profiles along the horizontal alignments. 

4. Tick Update Profiles if you want Autodesk® Vehicle Tracking to update the profiles automatically when 

the geometry changes.  This option is only available if Autodesk® Vehicle Tracking created the original 

profiles, i.e. if Create Profiles is ticked. 

5. Tick Create Corridor to create a 3D corridor model using default assemblies. 

6. Tick Update Corridor if you want Autodesk® Vehicle Tracking to update the corridor automatically 

when the geometry changes.  This option is only available if Autodesk® Vehicle Tracking created the 

original corridor, i.e. if Create Corridor is ticked. 

7. By default the corridor is built using simple assemblies consisting of just a road surface with no 

kerbs.  This is the case when Use Simple Road Assembly is ticked.  These assemblies are based 

upon the Civil 3D Primary Road Through Intersection assembly with right and left subassemblies 

renamed to offside and nearside in accordance with your driving convention. 

 

Un-tick Use Simple Road Assembly to use more complex assemblies for the entry and exit 

roads.  These assemblies are based upon the Civil 3D Primary Road Part Section – Daylight Right 

(or Left) again with right and left renamed to offside and nearside in accordance with your driving 

convention. 
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8. By default the assemblies are inserted on the crown lines and targeted to the nearside kerb and 

centreline alignments.  However under some circumstances it may be desirable to insert them on the 

nearside kerb alignment.  Switch between them with the Use Kerb Baselines checkbox. 

9. Normally you will probably want to construct the 3D model with calculated profiles; this is the default.  To 

drape the corridor on the surface tick Drape Corridor on Surface.  With this option enabled, the 

assemblies take their levels from the original surface profiles rather than the calculated profiles. 

For this class, please tick the following: 

  

Accept the default setting for Road Markings. 

If you want to make changes to these settings, you can still do it even after your roundabout 

has been created. 

Placing a new Roundabout 

Let’s get started by opening an existing drawing from this location: …\CV5226-Data\DWGs\ 

AU2014-Roundabout Design.dwg. In this drawing, I’ve already pre-defined the alignments 

which we will use as the target alignments. To place a new roundabout, go to Vehicle 

Tracking Ribbon tab, Junctions Panel >New Roundabout 
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In this class, we will pick TD16/07: Normal Roundabouts (Single Carriageway Intersection), 

then click Proceed. You will be prompted if you want to make ‘British Junction Design 

Standards’ as the default standard, click No. 

 

The first step is to add a road to a roundabout, you will need to be able to pick the alignment. 

Give it a name, say MS-Roundabout, pick an appropriate Appearance for Draw Style. Under 

Surface, pick EG for Existing Surface but leave the Final Surface as [Undefined], click OK. 

A number of libraries are provided with the program and these may be used as the basis for your own company 

libraries.  Whatever they relate to, libraries are grouped by nationality so, for example, the UK parking standards 

are held within a library file called UK_xxx.ATP, where xxx is the most recent version of Autodesk® Vehicle 

Tracking that can read it, e.g. UK_890.ATP. 



Civil3D Interoperability: Making the Infrastructure Suite work for you 

21 
 

 

Next, you will be presented with a series of prompts. When prompted to ‘Select the location 

of the center of the new roundabout’ pick the intersection of the 2 alignments (MS02 and 

MS03). 
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Next, follow the prompt to select the arms of the roundabout. 

 

Once you finished selecting the arms, right-click on the screen and it will start to model the 

roundabout. 

You will get a complete 3D roundabout with corridor, road markings and it also comes with 

Design Check.  
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Roundabout retouch 

There is probably a few minor touchup before we export this to 3DS Max. You will notice that 

there is some gaps appearing in the corridor. To quickly get rid of them, right-click on MS-

Roundabout corridor, and click on Properties. Go to Parameters tab, click on Set all 

Frequencies. 
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Under Offset Target, set both At alignment geometry points and At offset target geometry 

points to Yes. 

 

And finally, you will noticed that the corridor surface appears a little jagged .  

 

The trick to getting rid of the jagged lines is to use corridor feature line instead of links when 

defining the surface. You can easily do that by going into the Corridor properties>Surface 

tab, then do each of the following: 
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1. Data types: Select Feature lines 

2. Specify code: Flange, Flowline_Gutter, Top_Curb and Daylight. (This depends on the 

subassembly you used for your corridor model.) 

 

There you go, you will now have a pretty looking surface.  

 

 

 

 



Civil3D Interoperability: Making the Infrastructure Suite work for you 

26 
 

3DS Max and Civil View 

Please open AU2014-Roundabout Design-Complete.dwg from the …CV5226-Data\DWGs 

folder. Go to Output Ribbon tab, Export panel and click on Export to 3ds Max Design. 

 

In 3DS Max Design, go to Civil View tab and you will see Initialize Civil View if you are 

accessing this tab for the first time. 

 

Once you click on Initialize Civil View, you will be presented with the Initialize Civil View 

display box. Under System Units, select Meters, for Country, pick AU and for Start Mode, 

Automatic. 

 

You may need to close and re-start 3DS Max in order to access the Civil View tab. 
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Before we import the vsp3d file which we exported from Civil 3D, we need to set the units 

correctly.  

For this class, we will pick Custom and in the customer box, enter 1 = 1.0 Meters 

 

Geometry Import from Civil 3D 

Next, we go to Civil View tab>Geometry Import>Civil 3D (VSP3D).  

 

In the Civil 3D Import Panel, click Open and browse to …\CV5226-Data\Civil View\ AU2014-

Roundabout Design-Complete.vsp3d, then pick all the Corridor Baseline, Corridor Surface 

and Surface. Click OK and Yes when prompted. 

. 

It is important to note the distinction between System and Display units. Display units only affect how 

geometry is displayed in the viewports. System units determine the actual scale of geometry. For 

example, if you import a DXF file (unitless) containing a 1 x 1 x 1 Box, 3ds Max could import the box’s 

dimensions in inches or miles, depending on the System unit. This can have a significant impact on your 

scene, which is why it's important always to set up the system unit before you import or create geometry. 
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Civil View Global Shift Values 
Civil-engineering data are often based on survey coordinates. These can be very large values that are not 
suitable for use in 3ds Max Design. 
The Civil View Global Shift Values set up an XY shift that transforms imported geometry so it is close to the 
scene origin (0,0,0). This avoids the problem of large coordinates, which can slow down 3ds Max Design 
and reduce accuracy. 
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We will use a lot of the interface found in the Civil View Explorer as it provides an overview 

of the current state of a visualization, and direct access to the most commonly edited 

parameters of each object or other element in the scene. The Civil View Explorer can be 

accessed via Civil View menu > Civil View Explorer. You can dock the panel to the left.  

Once the import is completed, we will drape the aerial image on the existing ground. To do 

this, activate/select the existing ground (imported as checkered black and white), and this 

will automatically be highlighted under the Object List>Surfaces. Under Surface Parameter, 

go to Draping tab and click on Choose Bitmap… Browse to ...CV5226-Data\Civil View\Aerial 

Image\1.jpg. 
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Road markings and Object placement 

Next, we can start placing road markings and objects like vehicle, street lamps, trees etc on 

the model to make it more realistic. We will start by placing the Road markings first. To do 

that, go to Civil View menu>Civil View>Road Markings Style Editor… 

 

In the Road Marking Style Editor, click on   to add a new element to the current road 

marking style. Then, click on the  icon to allow for more than one road-marking object to 

be applied to each parent shape. Next, click on Pick Label Shape and then click in a 

viewport to pick a shape object. 

 

You can also click on  to open a previously created road marking style. I’ve saved it in 

…\CV5226-Data\Civil View\Road Marking Styles\CV5226-RDMarkingsRoundabout.rms 

Click Apply and OK. 
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Next, we will place some cars and street lamps on the roundabout. You will need to bring up 

the Object Placement Style Editor… from Civil Menu>CivilView> Object Placement Style 

Editor… 

 

In the Object Placement Style Editor, click   to add a new element to the current Object 

Placement Style. Under the Vehicle tab, select Cars and pick a model. Then click on 

 and then click one of the roundabout baseline as the shape 

object. Similarly, click on Parent Surface and select the surface close to the baseline you 

picked earlier. For Longitudinal Placement, pick Multiple (Regular Interval) and set the count 

to 20. 

Set Animation Options to -60km/h.  

For Lateral Placement, set Horiz Offset: to -1.75 and Rotation to 180.  

See the parameters for Object Placement Style Editor for Random [Cars] below: 
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Repeat the steps but instead of Vehicles, select Furniture>Lamp Column. See below: 

  

Click Apply and OK. Repeat the same for the other baselines for the roundabout. 

You can also open the Object Placement Styles from …\CV5226-Data\Civil View\Object 

Placement Styles\ CV5226-Vehicles and Lights-Arm 1-MS02ops.ops 
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There you have it, the finished roundabout. 

 

To view the animation, just click play. The main animation controls are found at the bottom of 

the program window, between the status bar and the viewport navigation controls, along with 

the time controls for animation playback within viewports. 

 

 

 


