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SE6666 Are you working on projects that require non-standard structural elements? Have you 

struggled with those shapes communicating across your analytical and Revit software models? This 
class will cover many things, including how to develop custom families that communicate bi-directionally 
between applications; how to properly map elements across models; how to develop an efficient, fluid, 
bidirectional workflow to avoid redundancy, increase coordination, and produce high-quality design 
documents and models; and how to integrate industry-standard third-party analysis tools (such as 
ETABS software) in a holistic workflow. 

Learning Objectives 
At the end of this class, you will be able to: 

• Discover the procedure for developing a workflow between Revit Structure software and third-party 
analysis tools. 

• Discover the steps required for creating bi-directionally enabled custom structural content. 

• Understand organizational techniques for producing a clear, efficient design model and document 
set. 

• Discover external tools available for efficiency and productivity gains. 

 

About the Speakers 

Raul is currently the Building Information Modeling (BIM) manager at Halvorson and Partners, a 

structural engineering firm in Chicago. Raul provides training and support, and he is involved on projects 

using Revit Structure software. Raul’s experience expands over 25 years in the use of CAD and BIM 

applications. In his previous role as the digital design manager in the Chicago office of Skidmore, 

Owings, & Merrill LLP (SOM), he was responsible for BIM implementation, and he oversaw the 

implementation of digital design technology, visualization, and sustainable and building performance 

analysis applications. Raul has worked on various high-rise and high-profile projects around the world. 

 Email: rpacheco@hpse.com  

 Twitter: Raul_Pach214 

Thomas works primarily as a structural engineer at Halvorson and Partners, but he also spends a 

considerable amount of time developing BIM software integration tools. He continues to look for new 

ways to increase office efficiency and bridge the gap between engineer and draftsman. 

 Email: tmendez@hpse.com 
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Class Overview 

The main idea behind Autodesk’s Revit Structure has always been to provide structural engineers with a 

single application that can facilitate the analysis, design, and documentation of their projects from start to 

finish. Although Revit Structure provides some very powerful structural analysis tools, the stubbornness of 

structural engineers usually results in a disconnect between the analysis, design, and documentation 

processes. Whether it’s due to the lack of trust in new/different structural analysis tools, or the fear of the 

initial loss of efficiency and/or aggravation usually associated with workflow changes, a structural 

engineer almost always refers back to their preferred structural analysis software package when 

beginning a new project.  

One of the biggest improvements the Autodesk development team made to Revit Structure to address 

this issue was to include an Application Programming Interface (API). The addition of an API paved the 

way for structural analysis software companies to development integration tools that could communicate 

both with their structural analysis software and Revit Structure. These tools aim to bridge the gap 

between structural analysis software and Revit Structure by providing the functionality to import/export 

models to and from Revit Structure.  

In this class we will demonstrate how Halvorson and Partners utilizes some of these integration tools in 

practice. We will describe the advantages of using third party integration tools as well as the challenges 

we encountered by doing so. We will also demonstrate how we use custom families to develop a bi-

directional workflow to produce holistically integrated 3D Building Information Models and complete 2D 

design documents. Lastly, we will present tools that we have developed in-house to overcome some of 

the challenges and limitations of the commercially available products. 
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Commercially Available Workflow Tools Example : CSiXRevit 

Computers and Structures, CSI, is the developer of ETABS, SAP2000 and other structural analysis 

programs. ETABS and SAP2000 are widely used in our office to design mid to super tall structures. We 

will be demonstrating the practical usages of the CSI developed "CSxRevit Add-in" which provides the 

functionality to import/export CSI models to and from Revit. The Add-in is available for Revit Structure 

2013, 2014 & 2015. 

Four different Workflows Supported 

1. Export From Revit Structure to develop new ETABS Model 

2. Export From Revit Structure to Update an existing ETABS Model 

(In this case you have the option of updating location of members, update the designs or update 

both)        

3. Import from ETABS to Create  a New Revit Project 

4. Import from ETABS to Update an Existing Revit Project 

Frame Section 

 

1. ETABS first tries to map Revit Family sections in the loaded ETABS database by comparing 
section names. If it finds a match then that section is mapped. All geometric cross sectional 
properties are used from the ETABS section 

2. If a Revit Family section cannot be mapped to an ETABS section from any of the property files, 
ETABS checks if it is a Revit parametric section. If it is a parametric section, ETABS creates an 
equivalent section and names it after the Revit family section.   

3. If a Revit family section is not parametrically defined, then a new ETABS section named after the 
Revit family section is created with default ETABS section properties. At this point the user is 
given the option to add a new parametric section to replace that section or to load a new section 
from any other section property file(.XML) that is not in the properties file (.XML) list. 

 

ETABS to Revit Translation 

For this case study only structural frame elements were part of the import and export process.  

Developing Custom Families 

Start with a typical Out of the box OOTB H-shape family from the Chinese Revit Structure library. If you 

are working on projects in China it is recommend to use the appropriate content for the region. For most 

typical projects rolled shapes will work just fine especially if integrating Revit with an analysis application.  

Chinese content is packaged with the Revit installation package. You will need to install it or have your IT 

support staff install it.  

Make sure you install the correct content with English folder structure. The only Chinese content with 

English folder structure is the South Asia content. This is found in the installation content under Other 

English. 

 

From the Control Panel under Programs > Programs and Features 

For Autodesk Revit Structure 2014 it is under Add or Remove Features 
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For Revit Structure 2015 it is under Autodesk Revit Structure Content libraries  

 

 

1. Add remove Features 

2. Select South China checkbox 

3. From the default content drop down list select Other English - South China 

4. Click add Content. 

 

Content will be installed under C:\ProgramData\Autodesk\RVT 201x\Libraries\South Asia\Structure    

  

For best practice open an OOTB family to begin creating a custom Built-up Plate family. There is also a 

family template “Metric Structural Framing - Beams and Braces.rft” that can be used. The template does 

not have predefined parameters.  

 

Use the medium and fine extrusions to develop the Built-Up Plate family. Add two reference planes for 

the top and bottom flange plate and 2 reference planes for the web thickness add a dimension for the 

web reference planes and assign the predefined tw parameter. Add dimensions for the top and bottom 

flange plates and assign the predefined tf parameter. The next step is to edit the sweep to create the top 

and bottom flanges. The Medium sweep was used for the top and bottom flanges and the fine sweep for 

the web thickness as sketch profiles. The original Line Stick Symbolic Lines were used. An advantage to 

start with an OOTB family is a time saving technique.  
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                 4 Reference planes added                                                   3D view of Buil-Up Shape family 

 

Add a family type parameter d2 with a formula d= d - (2 * tf) to subtract the top and bottom flange 

thickness. A formula was added for the area A = (tf * bf * 2) + (tw * d2). This can be used to calculate 

areas at a later time. Under Visibility Graphics modify the sweeps visibility settings to Detail Levels as 

Medium and Fine. 
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A similar process was used to develop a Built-UP Box Shape Custom Family started with an OOTB Tube 

family: 

 

             4 Reference planes added                                   3D view of Built-BOX Shape family 

A column Built-Up Box shaped was developed using a similar process.  
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                                                              Views of Tapered Built up box shaped  

This family has a little of everything. Tapered Section boxed shape with and without a stiffener plate or 

web plate.  

Generating a Type Catalog file for custom families 

To create a type catalog for the custom families follow the steps outlined below: 

 

1. Open one of the custom families 

2. In the family types create up to six new types 

Only parameters with values in the family will be exported to the type catalog file create a 

type catalog using the Export Family Types tool 

3. Click File > Export > Family Types 

  

The export creates a type catalog a file in the same directory where the family was saved and assigns the 

same name as the family but with a “.txt” extension. 

  

4. Click Save. 

5. Open the .txt file in a text editor 

6. The first line in the text file is the parameter declaration 

  

With the type catalog saved you can use excel or a text editor of your choice to add additional family 

types. In this case study Microsoft Excel was used for our workflow to add additional family types. 



Beyond the Box: Integrating Custom Structural Shapes, Analytical Models, and Revit Structure 

8 
 

 

The fields to generate type catalogs for the custom families were extracted from the ETABS generated 

section properties output file. A macro was used to filter and export only the values needed for each 

family type 

 

1. Destination file 

2. Filter the Family Name: (i.e. beam, Brace or Column) 

3. Filter Section Property: (i.e. Tube, Box, Wide Flange) 

4. Get Tex Button: Generates the catalog file 

5. Exported values to the type catalog file 

    

 

 Image of the BH-Shape-Beam.txt file 
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List of Custom Families Created for this project 

BU-H-Shapes 

BU-H-Braces 

BU-BOX-Shapes 

BU-BOX-Braces 

BU-BOX-Columns 

 

In-Place Families 

ETABS does not support in-place-families and will not transfer from Revit to ETABS 
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Importing an ETABS Model into Revit Structure 

 

Steps for Importing ETABS generated .EXR file  

 

1. Pre load all custom generated family types into a new project 

2. From the Add-Ins Tool > External Tools > Import to Create New Revit Structure Project from 

ETABS/SAP2000 

3. Select the .EXR file to Import 

 

For this import there were 51 Frame Section Warnings 
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                           Image: Frame Section Mapping 

Frame section mapping showing in red missing family types 

 

You have two options: 

  

1. Manually map the frame sections 

2. Go back to the excel file to generate the missing frame sections and load them into the 

project 
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                                Image: Frame Section Mapping 

After all sections have been mapped or reloaded into the project the model is ready to be imported 

Sloping Columns 

ETABS Model as Brace elements 

Challenges 

Creating Type Catalogs 

Creating custom families and type catalogs is a time consuming endeavor. But with careful planning and 

leveraging the information from the ETABS out put file in conjunction with excel to extract only the 

information needed to create type catalogs this task is attainable.  

X-Bracing  

ETABS Splits X-bracing into 4 segments at intersection of frame elements. In Revit X-bracing is typically 

modeled as two frame elements. 
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Exporting a Revit Model to ETABS 

Structural Columns and Framing:  

Frame Sections:  

The family type assigned to the Revit element is imported along with the whole family. ETABS converts 

the Revit family to an ETABS auto selection list 

  

Insertion Points: In Revit, the beam insertion point is defined by the following two parameters:  

Z-Direction Justification  

Lateral Justification  

Frame Section 

The Mapping of Revit frame sections attributes depends upon their type 

1. ETABS first tries to map Revit Family sections in the loaded ETABS database by comparing 
section names. If it finds a match then that section is mapped. All geometric cross sectional 
properties are used from the ETABS section 

2. If a Revit Family section cannot be mapped to an ETABS section from any of the property files, 
ETABS checks if it is a Revit parametric section. If it is a parametric section, ETABS creates an 
equivalent section and names it after the Revit family section.   

3. If a Revit family section is not parametrically defined, then a new ETABS section named after the 
Revit family section is created with default ETABS section properties. At this point the user is 
given the option to add a new parametric section to replace that section or to load a new section 
from any other section property file(.XML) that is not in the properties file (.XML) list. 

4. Revit In-Place Families elements are not supported in ETABS and will not import from Revit. 

  

Levels 

Building Story 

This is the datum level corresponding to a building functional story. In our workflow this is the top of the 

structural floor slab.  

Structural Level  

In Revit 2013 a structural level was introduced which identifies the level as primarily structural. In the 

OOTB Structural Template this parameter is disabled. We have enabled this parameter in our project 

template and assigned to their own Workset and labeled as T/Stl Level X. 

All steel framing elements are hosted to the Structural Level 
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          Image: showing Story Level and Structural Level 

Analytical Nodes 

Filters 

New in 2014 analytical filters come preloaded in the Structural template.  

Tip! When upgrading your company template as best practice is to start with a clean OOTB template to 

take advantage of enhancements. 

Prior to Exporting from Revit it is recommended to review all nodes and make sure they are analytically 

connected. In a 3D view add the two Analytical Node filters and assign a color to each one.  

 

Under visibility graphics turn on Analytical nodes  
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From the Filters tab add the two filters Unconnected Analytical Nodes and Connected Analytical Nodes 

for our case study two colors were used: 

 

1. Green was assigned to connected nodes 

2. Red was assigned to unconnected nodes 
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                                          Image: Showing Color Coded Filter   

 

  

                      Image: showing Connected green and Unconnected Analytical Nodes  

Manually connect all unconnected nodes. For the most part connecting the graphical element will fix the 

unconnected nodes.  Another Method is by selecting the analytical element and using the Analytical 

Adjust button from the anlytical model tab. This can be a tedious process depending on the number of 

unconnected nodes that exist in your project. With proper planning you can have a clean model to export 

to an analysis application.  

By performing the steps outlined above you will have a cleaner model to export. 

 

RevitStructureBlog: has a video demonstrating the use of these filters and assigning color to them 

https://www.youtube.com/watch?v=J2_iddaJzLg 
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Exporting a Revit Model to an EXR file 

For this process two levels of framing were selected along with the Grid lines  

1. From the Add-Ins menu 

2. Under External Tools > Export to Create a New ETABS/SAP200 Model 

 

 
 

3. In the Export to Create a New ETABS/SAP200 Model check Revit Structure Selected Objects 

Only Click OK 

 

 
             Image: displaying elements processed 

4. The file will be save with an .EXR extension to be imported into ETABS  
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Linked Models: 

Revit Models with Linked Structural Models will not export to an EXR file. You will need to export linked 

models separately.  

Import EXR file into ETABS 

For this Case Study a Chinese Steel Section Database was used using the Built-in Settings in the image 

below: 

 

               Image: Model Initialization 

Import > the Revit Structure.exr file into the ETABS model 

The first dialogue box you will get is the Revit Data Overview/Control dialog box 

With warnings. There are a total of two warning for Material and 32 for Frame Sections 

At this point you have two options  

 

1. Select the edit button to define equivalent fame sections in ETABS 

2. Select Import Mapping file 
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               Image: Revit Data Overview/Controls  

Mapping file 

Mapping file with section properties  

Revit Structure Section Name ETABS Section Name 

 

                                                  Sample mapping file  

A predefined a mapping file was created using Microsoft excel and exported to a text file. You can use a 

text editor of your choice.  

  

Note: This file can resides in the same location as your project or on your company server for use on 

other projects.  

  

After importing the mapping file the warnings were reduced to 2. For best practice is recommended that 

you predefine all your custom shape in the mapping file to reduce or eliminate warnings.  

  

CSiXRevit documentation states that if a frame section is not found ETABS will try to create an equivalent 

section. 
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                      Image: Revit Data Overview/Controls 

For the Material warnings since there were only two they can be manually mapped by selecting the edit 

button and choosing the appropriate material type. Material can also be mapped at the end of the 

mapping file under Total Material Assignment section.     

 

           Image: Mapping file Showing Total Material Assignments Table 

Round Trip 

For this case study only a few framing elements were changed to import back into Revit 

  

Partial Import from ETABS to Revit 

Changed frame types in ETABS for a partial import to Revit 

A built-up section was change to a box section  

Floor framing section properties were changed from HSS900x298 to a Built-up H1000 section property 
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Partial export of only frame elements changed 

  File > Export > Revit Structure.exr file  

  When prompted to Export only the selected objects click ok 

 

Before importing the ETABS to Revit Partial Update the edge frame elements were tagged as 

HN980X298X17X26 

After the ETABS to Revit partial update was completed tags automatically updated to a Built-up shape 

H1000   

Challenges 

Framing at the same level as floor slab 

Groups do not export 

Revit Framing Elements in Groups do not export to ETABS 

Ungroup all groups prior to using the CSiXRevit Export to ETABS 

 

Structural Levels & Story Levels imported: When Levels were not selected as part of the export process 

the CSiXRevit Exports both the Story Level and the Structural Level to the .EXR file resulting in some 

frame elements showing up in the Story Level and Some in the Structural Level. Even when frame 

elements were hosted to the Structural Level.  

  

Even when only Structural Levels were slected and not the story levels when exporting from Revit to 

ETABS. This did not prevent framing elements from importing to ETABS into multiple Levels.  
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H+P Software Suite 

Description 

The H+P Software Suite is a collection of in-house software tools deployed by 

means of a Dashboard Application, an Excel Add-in, and a Revit Add-in. 

Embedded at the heart of the H+P Software Suite is an API framework that 

encompasses the functionality of all the modeling applications used within our 

office.

Structural Analysis Applications 

RAM Structural Systems 

ETABS 

SAP2000 

Strand7 

Documentation 

Applications 

Rhinoceros/Grasshopper 

Revit 

 

Goals 

• Must be efficient. No repeated code. No unnecessary hard drive read/write operations. 

• Must be scalable. Adding new functionality cannot break old functionality. 

• Importing/Exporting Models 

� Must be able to send any model from any application to any other application. 

� Information should not be unnecessarily duplicated. No global database with "master" 

information. 

� Must be able to compare models to one another both before and after import/export 

operations. 

� Must support "nodes", "lines", and "areas". 

Revit Specific Goals 

• Very little effort must be required to extend functionality to future versions of Revit. 

• Tools must be available from outside of the Revit Interface. 

� Since we don't have access to the proprietary file formats that these programs use, we must 

start instances of the programs in order to read model information. 

o As a result, we may need to start separate x86 and x64 processes to access two models 

simultaneously; each of which may use a program built for a different architecture. 

� This is also necessary to run automated tools that may not require user interaction. Model 

maintenance tools, for example. 

• Must be tailored to our structural analysis and documentation style. 

� For example, there must be an understanding that steel floor framing may be modeled 

differently in a Revit model than it will be in a structural analysis model. 

� As another example, there must be an understanding of what link beam modeling techniques 

are used in each program. 

• Importing/Exporting 

� Revit specific information must not be lost when importing updated information. 

� Whatever gets imported must get exported. If we change the information in Revit to reflect a 

more documentation oriented standard, we must not lose the original information. 
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� We must keep track of any unexpected changes Revit might make to each element that we 

import. 

In order to meet these goals, we have developed custom families with custom parameters, and custom 

Revit Add-ins that facilitate the assignments of these parameters. 

Workflow Demonstration 

• Import an ETABS 2013 Model to a new Revit 2014 model. 

� Note any changes that Revit made to our imported information. 

• Make documentation specific changes in the Revit 2014 model. 

� We must do this without losing the analysis model information in case we want to re-import or 

export. 

• Re-import an updated version of the ETABS 2013 model into Revit 2014. 

� We must do a location based search for each element in Revit and then make sure its 

information is up do date. We also create new elements that didn't exist before, and delete 

elements that no longer exist. 

• Compare Revit 2014 Model to ETABS 2013 Model in Excel. 

� It's always good to compare models to make sure our tools are behaving the way we expect 

them to. 

• Export Revit 2014 Model to Strand7.  


